XI(4) NetBSD Kernel Interfaces Manual XI(4)
xi -- Xircom CreditCard Ethernet device driver
xi* at xirc? Configuration of PHYs may also be necessary. See mii(4).
The xi driver provides support for the Xircom CreditCard family of PCMCIA Ethernet adapters. Supported cards include: Xircom CreditCard Ethernet II Xircom CreditCard 10/100 Ethernet Xircom RealPort 10/100 Ethernet + Modem (Ethernet function only) Intel EtherExpress Pro/100 Compaq Netelligent 10/100 Cards which should work, but have not been confirmed include: Xircom RealPort Ethernet Xircom RealPort 10/100 Ethernet Some Xircom Ethernet products are supported by the tlp(4) driver.
Media selection is done using ifconfig(8) using the standard ifmedia(4) mechanism. Refer to those manual pages for more information.
ifmedia(4), mii(4), netintro(4), pcmcia(4), tlp(4), xirc(4), ifconfig(8)
The xi device driver appeared in NetBSD 1.5.
The driver suffers from poor performance. Even with the 10/100 cards, do not expect more than ~450KB/s. Some 10/100 cards may not autonegotiate reliably and require manual media selection. The Xircom multifunction cards which contain both Ethernet and modem interfaces are known to have problems. This is due to the card not reporting itself correctly as a multifunction card. NetBSD 8.1 June 1, 2007 NetBSD 8.1
You can also request any man page by name and (optionally) by section: