XENNET(4) NetBSD/xen Kernel Interfaces Manual XENNET(4)
xennet -- Xen frontend paravirtualized network interface
xennet* at xenbus?
The xennet interface forms the frontend part of the paravirtualized driv- ers used by Xen guest domains to have network connectivity. When the host domain is NetBSD, the endpoint of the xennet interface is a xvif(4) interface. In the XenStore, xvif and xennet are identified by ``vif'' (virtual interface) entries. Conceptually, frontends and backends drivers are similar to two Ethernet cards connected via a crossover cable. xennet interfaces can pass VLAN tagged packets.
xennet%d: can't read mac address, err %d The MAC address for this inter- face could not be read from XenStore. xennet%d: %s is not a valid mac address The MAC address specified in the configuration file of the newly created guest domain is invalid. xennet%d: using event channel %d The Xen event channel (virtual inter- rupt) ID associated to this xennet. xennet%d: using RX copy mode The xennet and its associated endpoint use copy mode for communication: packets are copied from one domain's memory to another.
bridge(4), ifmedia(4), xenbus(4), xvif(4), ifconfig(8)
The xennet driver first appeared in NetBSD 3.0.
The xennet driver was written by Manuel Bouyer <bouyer@NetBSD.org> and Christian Limpach <email@example.com>. NetBSD 9.0 April 5, 2020 NetBSD 9.0
You can also request any man page by name and (optionally) by section: