WSCONS.CONF(5) NetBSD File Formats Manual WSCONS.CONF(5)
wscons.conf -- workstation console config file
The wscons.conf file defines parameters regarding to the workstation con- sole (wscons). The file consists of lines starting with a keyword, and one or more arguments. Empty lines and lines starting with a hash (``#'') are ignored. This configuration file is used by the /etc/rc.d/wscons script which parses /etc/wscons.conf and runs wsconscfg(8), wsconsctl(8), and/or wsfontload(8) as configured. See rc.conf(5) for details on enabling the rc.d script. The following keywords and arguments are recognized: font name width height enc file Used to load a font via wsfontload(8). name gives a font name that can be used later, width can be used to specify the width of a font character in pixel, height is the same, just for the font characters' height. enc is used to declare the font's encoding, see the description on wsfontload(8)'s -e option for more detail. file gives the absolute path to the font file. See wsfontload(8) for more information. screen idx scr emul Add and configure virtual console number idx using a screen type of scr (e.g. 80x25) and a emul terminal emulation (e.g. vt100). See wsconscfg(8) for further parameter description. keyboard kbd Attach and configure keyboard kbd using ``wsconscfg -k''. If kbd is `-' or `auto', the first free keyboard will be used. See wsconscfg(8) for more information. encoding enc Set the keyboard map to the given language code enc, using ``wsconsctl -w encoding=enc''. The map must be supported by the keyboard driver in use and must be compiled into the ker- nel. See the keyboard driver's manpage (e.g., pckbd(4), ukbd(4)) for details. mapfile file Parses the contents of file, which contains a keyboard map per line, and calls ``wsconsctl -w map+='' for each line. See wsconsctl(8) for details. mux idx Used to attach and configure keyboard/mouse multiplexors, using ``wsconscfg -m idx''. See wsconscfg(8) for more information. setvar dev var val Set arbitrary wscons variable var to value val for specified control device dev. Can be used for direct modification of wscons(4) variables, when no other keywords are suitable. See wsconsctl(8) for more information. Command arguments can be specified as ``-'' which makes default values come into effect as described in the documentation of the utilities.
wscons(4), wsconscfg(8), wsconsctl(8), wsfontload(8) NetBSD 8.1 November 22, 2008 NetBSD 8.1
You can also request any man page by name and (optionally) by section: