WSCONS(4) NetBSD Programmer's Manual WSCONS(4)
wscons - console access
options WSEMUL_SUN options WSEMUL_VT100 options WSEMUL_NO_DUMB options "WSEMUL_DEFAULT=\"xxx\"" options WS_KERNEL_FG=WSCOL_XXX options WS_KERNEL_BG=WSCOL_XXX options WSDISPLAY_COMPAT_PCVT options WSDISPLAY_COMPAT_SYSCONS options WSDISPLAY_COMPAT_USL options WSDISPLAY_COMPAT_RAWKBD wsdisplay* at ... wskbd* at ... wsmouse* at ...
The wscons driver provides support for machine independent access to the console. wscons is made of a number of cooperating modules, in particular + hardware support for display adapters, keyboards and mice, see wsdisplay(4), wskbd(4), and wsmouse(4) + terminal emulation modules (see below), and + compatibility options to support control operations and other low- level behaviour of existing terminal drivers (see below) Terminal emulations: wscons does not define an own set of terminal con- trol sequences and special keyboard codes in terms of termcap(5). In- stead a ``terminal emulation'' is assigned to each virtual screen when the screen is created (see wsconscfg(8)). Different terminal emulations can be active at the same time on one display. The following choices are available: dumb This minimal terminal support is available unless the kernel op- tion options WSEMUL_NO_DUMB was specified at build time. No control sequences are supported besides the ASCII control characters. The cursor is not addressable. Only ASCII keyboard codes will be de- livered, cursor and functions keys do not work. sun The ``sun'' console emulation is available if options WSEMUL_SUN was specified at kernel build time. It sup- ports the control sequences of SUN machine consoles and delivers its keyboard codes for function and keypad keys (as far as pre- sent on the actually used keyboard). This emulation is suffi- cient for full-screen applications. vt100 is available with the kernel compile option options WSEMUL_VT100. It provides the most commonly used func- tions of DEC VT100 terminals with some extensions introduced by the DEC VT220 and DEC VT320 models. The features of the original VT100 which are not or not completely implemented are: + VT52 support, 132-column-mode, smooth scroll, light back- ground, keyboard autorepeat control, external printer sup- port, keyboard locking, newline/linefeed switching: Escape sequences related to these features are ignored or answered with standard replies. (DECANM, DECCOLM, DECSCLM, DECSCNM, DECARM, DECPFF, DECPEX, KAM, LNM) + Function keys are not reprogrammable and fonts can not be downloaded. DECUDK and DECDLD sequences will be ignored. + Neither C1 control set characters will be recognized nor will 8-bit keyboard codes be delivered. + The ``DEC supplemental graphic'' font is approximated by the ISO-latin-1 font, though there are subtle differences. + The actual rendering quality depends on the underlying graph- ics hardware driver. Characters might be missing in the available fonts and be substituted by more or less fitting replacements. Depending on the keyboard used, not all function keys might be available. In addition to the plain VT100 functions are supported: + ANSI colors + Some VT220 -like presentation state settings and -reports (DECRSPS), especially tabulator settings. In most applications, wscons will work sufficiently as a VT220 emulator. The WSEMUL_DEFAULT kernel option allows to select one of the described termi- nal options as default choice. The default gets into effect in kernel startup, i.e. for the operating system console or additional screens al- located through the WSDISPLAY_DEFAULTSCREENS option (see wsdisplay(4) ), or if no emulation type was passed to the wsconscfg(8) utility. Compatibility options: these options allow to run X servers or other pro- grams using low-level console driver functions which were written specif- ically for other console drivers to run on NetBSD systems. The options are in particular: WSDISPLAY_COMPAT_USL Support the protocol for switches between multiple virtual screens on one display as used by most PC-UNIX variants. WSDISPLAY_COMPAT_RAWKBD Allows to get raw XT keyboard scancodes from PC keyboards as needed by i386 X servers. WSDISPLAY_COMPAT_PCVT Emulates enough of the NetBSD / i386 ``pcvt'' driver to make X servers work. WSDISPLAY_COMPAT_SYSCONS Emulates enough of the i386 FreeBSD ``syscons'' driver to make X servers work. Useful with FreeBSD binary emulation. Linux/i386 X servers do usually run if the first two options are enabled together with the NetBSD Linux binary emulation. (To have programs looking for device special files of other console drivers find the wscons driver entry points, symlinks are a helpful mea- sure.) Other options: options WS_KERNEL_FG=WSCOL_XXX, options WS_KERNEL_BG=WSCOL_XXX, options WS_KERNEL_COLATTR="(WSATTR_XXX | WSATTR_YYY)" and options WS_KERNEL_MONOATTR="(WSATTR_XXX | WSATTR_YYY)" allow to make console output originating from the kernel appear differently than output from user level programs (via /dev/console or the specific tty device like /dev/ttyE0 ). ``WS_KERNEL_FG'' and ``WS_KERNEL_BG'' set the foreground / background used on color displays. The ``WSCOL_XXX'' arguments are colors as defined in /usr/include/wscons/wsdisplayvar.h. ``WS_KERNEL_COLATTR'' and ``WS_KERNEL_MONOATTR'' are additional attribute flags used on color or. monochrome displays, respec- tively. The arguments are defined in the same header file. Whether the attributes are supported or not depends on the ac- tually used graphics adapter. These options are ignored by the ``dumb'' terminal emulation. options WSCOMPAT_USL_SYNCTIMEOUT=nnn The virtual screen switching protocol enabled by ``WSDISPLAY_COMPAT_USL'' uses a somewhat complex handshake pro- tocol to pass control to user programs as X servers controlling a virtual screen. To avoid a non-responsive application to lock the whole console system a screen switch will be rolled back if the user application does not respond to a screen switch re- quest within some time. This option allows to set this timeout (in seconds), the default value is 5 seconds.
This man page is still extremely incomplete.
wsdisplay(4), wskbd(4), wsmouse(4), wsconscfg(8), wsconsctl(8), wsfontload(8) NetBSD 1.4 July 26, 1998 3
You can also request any man page by name and (optionally) by section: