WPA_PASSPHRASE(8) NetBSD System Manager's Manual WPA_PASSPHRASE(8)
wpa_passphrase -- Set WPA passphrase for a SSID
wpa_passphrase ssid passphrase
The wpa_passphrase utility pre-computes PSK entries for network configu- ration blocks of a wpa_supplicant.conf(5) file. It prints a single net- work configuration block to standard output. The following arguments must be specified on the command line: ssid The SSID whose passphrase should be derived. passphrase The passphrase to use. If not included on the command line, passphrase will be read from standard input. The passphrase must be 8 to 63 characters in length.
wpa_supplicant.conf(5), ifconfig(8), wpa_cli(8), wpa_supplicant(8)
The wpa_passphrase utility first appeared in NetBSD 4.0.
The wpa_passphrase utility was written by Jouni Malinen <firstname.lastname@example.org>. This manual page is derived from the wpa_passphrase.sgml file included in the wpa_supplicant(8) distribution. NetBSD 9.0 September 10, 2008 NetBSD 9.0
You can also request any man page by name and (optionally) by section: