ACPIWMI(4) NetBSD Kernel Interfaces Manual ACPIWMI(4)
acpiwmi -- Windows Management Instrumentation support for ACPI
acpiwmi* at acpi? wmidell* at acpiwmibus? wmieeepc* at acpiwmibus? wmihp* at acpiwmibus? wmimsi* at acpiwmibus?
The acpiwmi device driver provides an ACPI interface for Windows Manage- ment Instrumentation (WMI). The ACPI WMI interface is typically used to support vendor specific features found in various laptops. The following WMI mappings are supported: wmidell Dell laptops wmieeepc Some models of Asus Eee PC wmihp Hewlett-Packard laptops wmimsi MSI laptops The functionality varies from vendor to vendor. Typically the interface is used for function and hotkey handling, but additional features may be present.
acpi(4), acpidalb(4) Microsoft Corporation, Windows Instrumentation: WMI and ACPI, http://www.microsoft.com/whdc/system/pnppwr/wmi/wmi-acpi.mspx, December 4, 2001.
The acpiwmi device driver appeared in NetBSD 6.0.
Jukka Ruohonen <email@example.com> wrote acpiwmi and most of the mappings.
While WMI should provide a certain degree of portability across laptop models from a particular vendor, there is no guarantee that the mappings are functional in all models. The wmihp driver may conflict with hpqlb(4). NetBSD 9.0 May 27, 2019 NetBSD 9.0
You can also request any man page by name and (optionally) by section: