WI(4) NetBSD Programmer's Manual WI(4)
wi - Lucent Technologies WaveLAN/IEEE 802.11 PCMCIA wireless network driver
wi* at pcmcia? function ?
The wi driver provides support for WaveLAN/IEEE PCCARD adapters (also known as WaveLAN II cards). Note that while Lucent sells both ISA and PCMCIA WaveLAN/IEEE devices, the ISA product is actually a PCMCIA card in an ISA to PCMCIA bridge adapter. Consequently, the wi driver is required for both the ISA and PCMCIA NICs. Both the original 2Mbps WaveLAN/IEEE cards and the newer 6Mbps WaveLAN/IEEE Turbo adapters are supported. The core of the WaveLAN/IEEE is the Lucent Hermes controller. All host/device interaction is via programmed I/O with the Hermes. The Her- mes supports 802.11 and 802.3 frames, power management, BSS, WDS and ad- hoc operation modes. The wi driver encapsulates all IP and ARP traffic as 802.11 frames, however it can receive either 802.11 or 802.3 frames. Transmit speed is selectable between 1Mbps fixed, 2Mbps fixed or 2Mbps with auto fallback. For WaveLAN/IEEE Turbo adapters, speeds up to 6Mbps are available. By default, the wi driver configures the WaveLAN card for ad-hoc opera- tion. In this mode, stations can communicate among each other without the aid of an access point. To join a service set, the driver must be set for BSS mode using the wiconfig(8) utility. For more information on configuring this device, see ifconfig(8).
Cards supported by the wi driver include: Lucent Wavelan/IEEE 2.0Mb Bronze Lucent Wavelan/IEEE 2.0Mb Silver Melco AIR CONNECT WLI-PCM-L11 DEC/Cabletron RoamAbout 802.11 DS High Rate
wi%d: init failed The WaveLAN failed to come ready after an initializa- tion command was issued. wi%d: failed to allocate %d bytes on NIC The driver was unable to allo- cate memory for transmit frames in the NIC's on-board RAM. wi%d: device timeout The WaveLAN failed to generate an interrupt to ac- knowledge a transmit command. One reason can be that the board is mis- configured, see wiconfig(8).
arp(4), netintro(4), ifconfig(8), wiconfig(8) HCF Light programming specification, http://www.wavelan.com.
The wi device driver first appeared in NetBSD 1.4.3.
The wi driver was written by Bill Paul <firstname.lastname@example.org>. NetBSD 1.4 April 21, 1999 1
You can also request any man page by name and (optionally) by section: