USERMGMT.CONF(5) NetBSD File Formats Manual USERMGMT.CONF(5)
usermgmt.conf -- user management tools configuration file
The usermgmt.conf file defines the default values used by the user management tools, useradd(8) and friends. Options in this file can be set by manually editing /etc/usermgmt.conf or using the -D option to useradd(8). base_dir sets the base directory name, in which new users' home directories are created when using the -m option to useradd(8). class sets the default login class for new users. See login.conf(5) for more information on user login classes. expire sets the default time at which the current password expires. This can be used to implement password aging. Both the expire and inactive fields should be entered in the form ``month day year'', where month is the month name (the first three characters are sufficient), day is the day of the month, and year is the year. Time in seconds since the epoch (UTC) is also valid. A value of 0 can be used to disable this feature. group sets the default primary group for new users. If this is `=uid', then a uid and gid will be picked which are both unique and the same, and a line will be added to /etc/group to describe the new group. It has the format: group gid | name | =uid homeperm sets the default permissions of the newly created home directory if -m is given to useradd(8). The permission is specified as an octal number, with or without a leading zero. inactive sets the default time at which new accounts expire. A value of 0 can be used to disable this feature. Also see the expire field. password specifies an already-encrypted default password. preserve If this value is one of `true', `yes', or a non-zero number, then the user login information will be preserved when removing a user with userdel(8). range specifies the uid boundaries for new users. If unspecified, the default is ``1000..60000''. It has the format: range starting-uid..ending-uid gid_range specifies the gid boundaries for new groups. If unspecified, the default is ``1000..60000''. It has the format: gid_range starting-gid..ending-gid shell sets the default login shell for new users. skel_dir sets the default skeleton directory in which to find files with which to populate the new user's home directory. SYNTAX The usermgmt.conf file uses a simple syntax format. Each line must contain one option. That option must be in the front of the line (no spaces). Any number of white spaces such as ' ' and '\t' may follow. The line ends with a list of options from each.
/etc/usermgmt.conf /etc/skel/* /etc/login.conf
group wheel base_dir /home/ skel_dir /etc/skel shell /bin/sh inactive 0
login.conf(5), passwd(5), user(8), useradd(8), userdel(8), usermod(8)
The usermgmt.conf configuration file first appeared in NetBSD 1.5. NetBSD 8.1 February 9, 2016 NetBSD 8.1
You can also request any man page by name and (optionally) by section: