USCANNER(4) NetBSD Kernel Interfaces Manual USCANNER(4)
uscanner -- minimal USB support for scanners
uscanner* at uhub?
The uscanner driver provides minimal support for USB scanners. The driver recognizes a number of USB scanners, but to actually scan anything there needs to be software that knows about the particular scanner. The SANE package provides support for some scanners.
The uscanner driver works with the following scanners: Epson GT-7000 Perfection 610U Perfection 636U Perfection 1200U Perfection 1200U Photo Perfection 1260 Perfection 1660 Perfection 2400 HP ScanJet 4100C ScanJet 5200C ScanJet 6300C Many other scanners are recognized, but there is no software support for them yet.
scanimage(1), usb(4), usscanner(4) USB Scanners under Linux, http://www.buzzard.org.uk/jonathan/scanners- usb.html.
The uscanner driver appeared in NetBSD 1.6.
This driver should not really exist. The scanners it recognizes can be accessed through the ugen(4) driver instead. A proper scanner driver would provide a uniform interface to scanners instead of exposing the innards of the scanner. The reason the driver exists is to have some- thing that is compatible with the Linux driver. NetBSD 7.1.2 September 10, 2000 NetBSD 7.1.2
You can also request any man page by name and (optionally) by section: