URIO(4) NetBSD Kernel Interfaces Manual URIO(4)
urio -- USB driver for the Diamond Multimedia Rio500 MP3 player
urio* at uhub?
The urio driver provides support for Rio500 MP3 player from Diamond Mul- tiMedia. The driver implements minimal support to access the device and requires a user application for up and downloading music.
/dev/urio0 device node
Using the Rio500 package from sourceforge the command rio_add_song 01_BlinkarBla.mp3 will download a song over the USB connection into your Rio500.
usb(4) Rio500 project: http://rio500.sourceforge.net/
The urio driver appeared in NetBSD 1.5. This driver is based on a FreeBSD Rio driver written by Iwasa Kazmi. NetBSD 7.1.2 March 6, 2000 NetBSD 7.1.2
You can also request any man page by name and (optionally) by section: