UHIDEV(4) NetBSD Kernel Interfaces Manual UHIDEV(4)
uhidev -- USB Human Interface Device support
uhidev* at uhub? ucycom* at uhidev? reportid ? uhid* at uhidev? reportid ? ukbd* at uhidev? reportid ? ums* at uhidev? reportid ?
The uhidev driver handles all Human Interface Devices. Each HID device can have several components, e.g., a keyboard and a mouse. These compo- nents use different report identifiers (a byte) to distinguish which one data is coming from. The uhidev driver has other drivers attached that handle particular kinds of devices and uhidev only dispatches data to them based on the report id.
ucycom(4), uhid(4), ukbd(4), ums(4), usb(4)
The uhidev driver appeared in NetBSD 1.6. NetBSD 5.0 July 30, 2005 NetBSD 5.0
You can also request any man page by name and (optionally) by section: