UDP(4) NetBSD Kernel Interfaces Manual UDP(4)
udp -- Internet User Datagram Protocol
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_DGRAM, 0); int socket(AF_INET6, SOCK_DGRAM, 0);
UDP is a simple, unreliable datagram protocol which is used to support the SOCK_DGRAM abstraction for the Internet protocol family. UDP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). UDP address formats are identical to those used by TCP. In particular UDP provides a port identifier in addition to the normal Internet address format. Note that the UDP port space is separate from the TCP port space (i.e. a UDP port may not be ``connected'' to a TCP port). In addition broadcast packets may be sent (assuming the underlying network supports this) by using a reserved ``broadcast address''; this address is network interface dependent. There are two UDP-level setsockopt(2)/getsockopt(2) options. UDP_OPTIONS may be used to change the default behavior of the socket. For example: setsockopt(s, IPPROTO_UDP, UDP_OPTIONS, NULL, 0); The UDP_ENCAP option can be used to encapsulate ESP packets in UDP. There is one valid encapsulation option: UDP_ENCAP_ESPINUDP from RFC3948 defined in <netinet/udp.h>. Options at the IP transport level may be used with UDP; see ip(4) or ip6(4).
A socket operation may fail with one of the following errors returned: [EADDRINUSE] when an attempt is made to create a socket with a port which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a net- work address for which no network interface exists. [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is already connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been con- nected;
getsockopt(2), recv(2), send(2), socket(2), inet(4), inet6(4), intro(4), ip(4), ip6(4), rfc6056(7), sysctl(7) User Datagram Protocol, RFC, 768, August 28, 1980. Requirements for Internet Hosts -- Communication Layers, RFC, 1122, October 1989.
The udp protocol appeared in 4.2BSD. NetBSD 9.0 May 31, 2018 NetBSD 9.0
You can also request any man page by name and (optionally) by section: