UCOM(4) NetBSD Kernel Interfaces Manual UCOM(4)
ucom -- USB tty support
ucom* at u3g? ucom* at uark? ucom* at ubsa? ucom* at uchcom? ucom* at uftdi? ucom* at ugensa? ucom* at uhmodem? ucom* at uipaq? ucom* at ukyopon? ucom* at umcs? portno ? ucom* at umct? ucom* at umodem? ucom* at uplcom? ucom* at uslsa? ucom* at uvisor? portno ? ucom* at uvscom? ucom* at uxrcom?
The ucom driver attaches to USB modems, serial ports, and other devices that need to look like a tty. The ucom driver shows a behaviour like a tty(4). This means that normal programs such as tip(1) or pppd(8) can be used to access the device. The portno locator can be used to decide which port to use for device that have multiple external ports. Note that while ucom supports the (undocumented) pulse-per-second API normally used on conventional serial ports, USB serial devices typically have a varying latency around 1 ms due to the USB frame structure. The ttyXX devices are traditional dial-in devices; the dtyXX devices are used for dial-out. (See tty(4).)
tty(4), u3g(4), uark(4), ubsa(4), uchcom(4), uftdi(4), ugensa(4), uhmodem(4), uipaq(4), ukyopon(4), umcs(4), umct(4), umodem(4), uplcom(4), usb(4), uslsa(4), uvisor(4), uvscom(4), uxrcom(4)
The ucom driver appeared in NetBSD 1.5. NetBSD 9.0 April 12, 2020 NetBSD 9.0
You can also request any man page by name and (optionally) by section: