UCAS(9) NetBSD Kernel Developer's Manual UCAS(9)
ucas -- atomic memory operations on user-space address
#include <sys/systm.h> int ucas_ptr(volatile void *uptr, void *old, void *new, void *retp); int ucas_int(volatile int *uptr, int old, int new, int *retp);
These functions provide compare-and-swap (CAS) functionality on user- space address. Except that they can be safely used for the kernel to access user-space address, they are semantically equivalents of atomic_cas(3). uptr The pointer to the variable. This should be a user-space pointer. old The value to compare with the variable. new The value to store to the variable. retp The pointer to the memory to store the old value of the variable.
On success, these functions return 0. In that case, the caller can con- sult the value returned via retp to check the result of the CAS opera- tion. Otherwise, these functions return an appropriate errno(9) error code, typically EFAULT.
Conceptually, the retp argument of ucas_ptr() would be of void **. The current prototype is a compromise for usability. NetBSD 8.1 October 24, 2011 NetBSD 8.1
You can also request any man page by name and (optionally) by section: