U3G(4) NetBSD Kernel Interfaces Manual U3G(4)
u3g -- USB support for 3G datacards
To compile this driver into the kernel, place the following lines in your kernel configuration file: umodeswitch* at uhub? port ? u3g* at uhub? port ? ucom* at u3g?
The u3g driver provides support for the multiple USB-to-serial interfaces exposed by many 3G USB/PC Card modems. The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
The u3g driver supports the following adapters: · Huawei E171 · Huawei E220 (E270?) · Huawei Mobile · Novatel MC950D · NTT DOCOMO L-02C · Option Globetrotter 3G · Option Globetrotter 3G Fusion (only 3G part, not WLAN) · Option Globetrotter 3G Fusion Quad (only 3G part, not WLAN) · Option Globetrotter 3G Quad · Vodafone Mobile Connect Card 3G The supported 3G cards provide the necessary modem port for ppp, pppd, or mpd connections as well as extra ports (depending on the specific device) to provide other functions (diagnostic port, SIM toolkit port).
tty(4), ubsa(4), ucom(4), usb(4)
The u3g driver appeared in NetBSD 5.0. The ubsa(4) manual page was modi- fied for u3g by Andrea Guzzo <email@example.com> in September 2008.
The u3g driver was written by Andrea Guzzo <firstname.lastname@example.org>. Hardware for testing provided by AnyWi Technologies, Leiden, NL. NetBSD 9.0 October 8, 2017 NetBSD 9.0
You can also request any man page by name and (optionally) by section: