SDPD(8) NetBSD System Manager's Manual SDPD(8)
sdpd -- Bluetooth Service Discovery Protocol daemon
sdpd [-dh] [-c path] [-G group] [-g group] [-u user]
The sdpd daemon keeps track of the Bluetooth services registered on the host and responds to Service Discovery inquiries from the remote Blue- tooth devices. In order to use any service remote Bluetooth device need to send Service Search and Service Attribute or Service Search Attribute request over Bluetooth L2CAP connection on SDP PSM (0x0001). The sdpd daemon will try to find matching Service Record in its Service Database and will send appropriate response back. The remote device then will process the response, extract all required information and will make a separate con- nection in order to use the service. Bluetooth applications, running on the host, register services with the local sdpd daemon. Operation like service registration, service removal and service change are performed over the control socket. It is possible to query entire content of the sdpd Service Database with sdpquery(1) by issuing browse command on the control socket. The command line options are as follows: -c path Specify path to the control socket. The default path is /var/run/sdp. -d Do not detach from the controlling terminal. -G group Grant permission to members of the group to modify the sdpd Ser- vice Database. -g group Specifies the group the sdpd should run as after it initializes. The value specified may be either a group name or a numeric group ID. This only works if sdpd was started as root. The default group name is ``_sdpd''. -h Display usage message and exit. -u user Specifies the user the sdpd should run as after it initializes. The value specified may be either a user name or a numeric user ID. This only works if sdpd was started as root. The default user name is ``_sdpd''.
The sdpd daemon will listen for incoming L2CAP connections on a wildcard BD_ADDR. In case of multiple Bluetooth devices connected to the same host it is possible to specify which services should be ``bound'' to which Bluetooth device. Such assignment should be done at service registration time. Requests to register, remove or change service can only be made via the control socket. The sdpd daemon will check the peer's credentials and will only accept the request when the peer is the superuser, of if the peer is a member of the group specified with the -G option. The sdpd daemon does not check for duplicated Service Records. It only performs minimal checking on the service data sent in the Service Regis- ter request. It is assumed that application must obtain all required resources such as RFCOMM channels etc., before registering the service.
The sdpd daemon first appeared in FreeBSD 5.3 and was imported into NetBSD 4.0 by Iain Hibbert under the sponsorship of Itronix, Inc.
Maksim Yevmenkin <firstname.lastname@example.org>
Most likely. Please report if found. NetBSD 5.0_RC4 January 13, 2004 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: