RUMP_LFS(8) NetBSD System Manager's Manual RUMP_LFS(8)
rump_lfs -- mount the lfs file system using a userspace server
file-system PUFFS pseudo-device putter rump_lfs [options] special node
The rump_lfs utility can be used to mount lfs file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_lfs(8), rump_lfs does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty (starting from 10% and depending on the workload and file system in question), there is no dif- ference to using in-kernel code. In case mounting a file system image from a regular file, rump_lfs does not require the use of vnconfig(8) unlike kernel file systems. Instead, the image path can be directly passed as the special file path. The exception is if the image contains a disklabel. In this case vnconfig is required to resolve the start offset for the correct partition within the image. It is recommended that untrusted file system images be mounted with rump_lfs instead of mount_lfs(8). Corrupt file system images commonly cause the file system to crash the entire kernel, but with rump_lfs only the userspace server process will dump core. To use rump_lfs via mount(8), the flags -o rump and -t lfs should be given. Similarly, rump_lfs is run instead of mount_lfs(8) if ``rump'' is added to the options field of fstab(5). Please see mount_lfs(8) for a full description of the available command line options.
p2k(3), puffs(3), rump(3), mount_lfs(8)
The rump_lfs utility first appeared in NetBSD 5.0. It is currently con- sidered experimental. NetBSD 5.1 February 15, 2009 NetBSD 5.1
You can also request any man page by name and (optionally) by section: