RUMP_CD9660(8) NetBSD System Manager's Manual RUMP_CD9660(8)
rump_cd9660 -- mount the cd9660 file system using a userspace server
file-system PUFFS pseudo-device putter rump_cd9660 [options] special node
The rump_cd9660 utility can be used to mount cd9660 file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_cd9660(8), rump_cd9660 does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty (starting from 10% and depending on the workload and file system in question), there is no difference to using in-kernel code. In case mounting a file system image from a regular file, rump_cd9660 does not require the use of vnconfig(8) unlike kernel file systems. Instead, the image path can be directly passed as the special file path. The exception is if the image contains a disklabel. In this case vncon- fig is required to resolve the start offset for the correct partition within the image. It is recommended that untrusted file system images be mounted with rump_cd9660 instead of mount_cd9660(8). Corrupt file system images com- monly cause the file system to crash the entire kernel, but with rump_cd9660 only the userspace server process will dump core. To use rump_cd9660 via mount(8), the flags -o rump and -t cd9660 should be given. Similarly, rump_cd9660 is run instead of mount_cd9660(8) if ``rump'' is added to the options field of fstab(5). Please see mount_cd9660(8) for a full description of the available com- mand line options.
p2k(3), puffs(3), rump(3), mount_cd9660(8)
The rump_cd9660 utility first appeared in NetBSD 5.0. It is currently considered experimental. NetBSD 5.1 February 15, 2009 NetBSD 5.1
You can also request any man page by name and (optionally) by section: