PUD(4) NetBSD Kernel Interfaces Manual PUD(4)
pud -- Pass-to-Userspace Device
The pud driver enables the implementation of block and character device drivers as userspace daemons. The daemons register the device major num- ber they wish to handle. Registering a character device is mandatory, supporting the block device interface for same major device is optional. The major number must be available, i.e. another driver must not be reg- istered to handle the operation. After succesful registration the userspace daemon is supposed to handle the driver methods the kernel passes down to it.
This document is in a hit-in-the-head style obviously not even near com- plete. But that does not matter, as neither is the code. NetBSD 5.0_RC4 November 21, 2007 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: