PCWEASEL(4) NetBSD Kernel Interfaces Manual PCWEASEL(4)
pcweasel -- Support for the PC-Weasel serial console board
pseudo-device pcweasel weasel* at pci? dev ? function ? Note that the appropriate display device must also be enabled. See pcdisplay(4) for more information.
The PC-Weasel is a serial console board for use primarily on Intel-based PC-class systems. It addresses a problem that nearly everyone who has deployed a PC-class server has experienced: the total lack of remote man- agement capability on PC-class hardware. In addition to serial console support, the PC-Weasel provides the ability to remotely reset the system (by means of a hardware reset signal), and provides a watchdog timer function. The PC-Weasel works by emulating the original IBM Monochrome Display Adapter (MDA). Writes to the display's character cells are translated into ANSI terminal sequences which are then sent out the PC-Weasel's serial port. Incoming characters are translated into PC keyboard scan codes and then fed (by means of a cable) into the system's keyboard con- troller. The system believes it is using a display console. This is particularly important in the event that one needs access to BIOS config- uration menus. The PC-Weasel also includes a ST16550 serial port, which may be config- ured as any one of the system's serial ports. Typical usage is to con- figure the port as com0 at ISA I/O address 0x3f8. When the PC-Weasel detects activity on the ST16550, the serial port is automatically con- nected to the ST16550 so that the serial port may be used as normal. When the PC-Weasel detects activity on the internal UART used for MDA emulation, the serial port is automatically reconnected to the emulation UART. This allows the boot program and kernel to be configured to use the serial port directly (which is more efficient than using the MDA emu- lation mode), yet allows the MDA emulation to be reestablished as soon as the kernel loses control of the system. The pcweasel driver provides support for the additional features present on the PC-Weasel. At the moment, this includes support for the watchdog timer function. Use of the pcweasel driver is not required in order for the system to function with a PC-Weasel installed so long as only the MDA emulation and ST16550 serial port functionality is required.
The pcweasel driver first appeared in NetBSD 1.5.1.
The PC-Weasel was invented by Herb Peyerl and Jonathan Levine at Canada Connect Corporation. The pcweasel driver was written by Jason R. Thorpe <email@example.com>, and contributed by Zembu Labs, Inc. Herb Peyerl of Middle Digital, Inc. provided several firmware updates during the development of the driver. NetBSD 9.0 November 23, 2007 NetBSD 9.0
You can also request any man page by name and (optionally) by section: