ONEWIRE(4) NetBSD Kernel Interfaces Manual ONEWIRE(4)
onewire -- 1-Wire bus
onewire* at gpioow? option ONEWIREVERBOSE
1-Wire bus was originally developed by Dallas Semiconductor for connect- ing integrated circuits. It is commonly used for connecting devices such as electronic keys, EEPROMs, temperature sensors, real-time clocks, secu- rity chips, etc. The onewire driver provides a uniform programming interface layer between 1-Wire master controllers and various 1-Wire slave devices. Each 1-Wire master controller attaches a onewire framework; several slave devices can then be attached to the onewire bus. The driver supports plugging and unplugging slave devices on the fly.
gpioow(4) 1-Wire bus bit-banging through GPIO pin
owtemp(4) temperature family type device
The onewire driver first appeared in OpenBSD 4.0 and NetBSD 4.0.
The onewire driver was written by Alexander Yurchenko <email@example.com> and ported to NetBSD by Jeff Rizzo <riz@NetBSD.org>. NetBSD 9.0 April 4, 2006 NetBSD 9.0
You can also request any man page by name and (optionally) by section: