NVMECTL(8) NetBSD System Manager's Manual NVMECTL(8)
nvmectl -- NVM Express control utility
nvmectl devlist nvmectl identify [-x [-v]] device_id nvmectl logpage [-x] [-p page_id] [-v vendor-string] [-b] device_id|namespace_id nvmectl power [-l] [-p power_state] [-w workload_hint] device_id nvmectl wdc cap-diag [-o -path_template] device_id
NVM Express (NVMe) is a storage protocol standard, for SSDs and other high-speed storage devices over PCI Express. logpage The logpage command knows how to print log pages of various types. It also knows about vendor specific log pages from hgst/wdc and intel. Page 0xc1 for hgst/wdc contains the advanced smart information about the drive. Page 0xc1 is read latency stats for intel. Page 0xc2 is write latency stats for intel. Page 0xc5 is temperature stats for intel. Page 0xca is advanced smart information for intel. Specifying -p help will list all valid vendors and pages. -x will print the page as hex. -b will print the binary data for the page. wdc The various wdc commands retrieve log data from the wdc/hgst drives. The -o flag specifies a path template to use to output the files. Each file takes the path template (which defaults to nothing), appends the drive's serial number and the type of dump it is followed by .bin. These logs must be sent to the vendor for analysis. This tool only provides a way to extract them.
nvmectl devlist Display a list of NVMe controllers and namespaces along with their device nodes. nvmectl identify nvme0 Display a human-readable summary of the nvme0 IDENTIFY_CONTROLLER data. nvmectl identify -x -v nvme0ns1 Display an hexadecimal dump of the nvme0 IDENTIFY_NAMESPACE data for namespace 1. nvmectl logpage -p 1 nvme0 Display a human-readable summary of the nvme0 controller's Error Informa- tion Log. Log pages defined by the NVMe specification include Error Information Log (ID=1), SMART/Health Information Log (ID=2), and Firmware Slot Log (ID=3). nvmectl logpage -p 0xc1 -v wdc nvme0 Display a human-readable summary of the nvme0's wdc-specific advanced SMART data. nvmectl logpage -p 1 -x nvme0 Display a hexadecimal dump of the nvme0 controller's Error Information Log. nvmectl logpage -p 0xcb -b nvme0 > /tmp/page-cb.bin Print the contents of vendor specific page 0xcb as binary data on stan- dard out. Redirect it to a temporary file. nvmectl power -l nvme0 List all the current power modes. nvmectl power -p 3 nvme0 Set the current power mode. nvmectl power nvme0 Get the current power mode.
The nvmecontrol utility appeared in FreeBSD 9.2.
nvmecontrol was developed by Intel and originally written by Jim Harris <jimharris@FreeBSD.org>. This man page was written by Jim Harris <jimharris@FreeBSD.org>. NetBSD 8.1 May 19, 2016 NetBSD 8.1
You can also request any man page by name and (optionally) by section: