NSCLPCSIO(4) NetBSD Kernel Interfaces Manual NSCLPCSIO(4)
nsclpcsio -- National Semiconductor PC87366 LPC Super I/O
nsclpcsio* at isa? gpio* at nsclpcsio?
The nsclpcsio driver provides support for the National Semiconductor PC87366 LPC Super I/O. The Super I/O incorporates several logical devices, the following ones are supported: GPIO, VLM and TMS. The GPIO logical device provides 29 I/O pins which can be accessed through the gpio(4) framework. The gpioctl(8) program allows easy manipu- lation of the pins from userland. VLM and TMS logical devices provides hardware monitoring capabilities to be used with the envsys(4) API. The following 17 monitoring sensors are available: Sensor Units Typical Use TSENS1 uK Remote diode TSENS2 uK Remote diode TNSC uK Local diode VSENS0 uV DC External source VSENS1 uV DC External source VSENS2 uV DC External source VSENS3 uV DC External source VSENS4 uV DC External source VSENS5 uV DC External source VSENS6 uV DC External source VSB uV DC VSB VDD uV DC VDD VBAT uV DC VBAT AVDD uV DC AVDD TS1 uV DC Thermistor TS2 uV DC Thermistor TS3 uV DC Thermistor
The nsclpcsio device appeared in NetBSD 2.0.
The chip decodes address ranges which are not obvious and cannot be con- trolled by the kernel configuration file (must be set up by the BIOS). NetBSD 5.1 November 9, 2007 NetBSD 5.1
You can also request any man page by name and (optionally) by section: