NE(4) NetBSD Kernel Interfaces Manual NE(4)
ne -- NE2000 and compatible Ethernet cards device driver
ISA boards ne0 at isa? port 0x280 irq 9 ne1 at isa? port 0x300 irq 10 ne* at isapnp? MCA boards ne* at mca? slot ? PCI boards ne* at pci? dev ? function ? PCMCIA ne* at pcmcia? function ? acorn32 ne* at podulebus? amiga ne* at zbus0 # AriadneII ne* at xsurfbus? # X-Surf ne* at xshbus? # X-Surf 100 amigappc ne* at zbus0 # AriadneII ne* at xsurfbus? # X-Surf ne* at xshbus? # X-Surf 100 atari ne0 at mainbus0 # EtherNEC on Atari ROM cartridge slot evbarm ne0 at obio? addr 0x0e000200 intr 5 # on-board Asix AX88796 evbsh3 ne0 at mainbus? # Realtek RTL8019AS x68k ne* at intio0 addr 0xece300 intr 249 # Nereid Ethernet ne* at intio0 addr 0xeceb00 intr 248 # Nereid Ethernet neptune0 at intio0 addr 0xece000 intr 249 # Neptune-X neptune1 at intio0 addr 0xece400 intr 249 # Neptune-X at alt. addr. ne* at neptune? addr 0x300
The ne device driver supports NE2000 and compatible (including NE1000) Ethernet cards. While the original NE2000 is designed for ISA bus, the compatible Realtek 8019 chip is widely used on various local busses and ne driver also supports such devices on various machines.
The Realtek 8019 (ISA, ISAPnP, some PCMCIA) and Realtek 8029 (PCI) NE2000-compatible Ethernet chips include support for software media selection. Some cards based on AX88x9x chips (like X-Surf 100) also support media selection and link auto negotiation through the mii(4) interface. If one of the above chips is detected by the driver, the list of sup- ported media will be displayed. For all other chips supported by the ne driver, media selection must be performed either via card jumper settings or by vendor-supplied configu- ration programs.
ne0: where did the card go? The driver found the card, but was unable to make the card respond to complete the configuration sequence.
ifmedia(4), intro(4), isa(4), isapnp(4), mca(4), pci(4), pcmcia(4), ifconfig(8) NetBSD 9.0 August 14, 2013 NetBSD 9.0
You can also request any man page by name and (optionally) by section: