MSTOHZ(9) NetBSD Kernel Developer's Manual MSTOHZ(9)
mstohz, hztoms -- convert between milliseconds and system clock ticks
#include <sys/param.h> int mstohz(int ms); int hztoms(int hz);
The mstohz() macro can be used to convert time in milliseconds to system clock ticks, as used by the callout(9) facility, in an integer-overflow safe way. Conversely, hztoms() converts system clock ticks to millisec- onds. These macros are defined in the <sys/param.h> header. Individual ports can have a processor-specific, more efficient version implemented in their <machine/param.h> header as a define.
The return value is either the number of clock ticks or milliseconds for the specified value.
param(3), callout(9), tvtohz(9)
Neither mstohz() nor hztoms() make use of expensive 64-bit integer arith- metic. The result from mstohz() will be rounded down to one second if the parameter is larger than 131072 milliseconds. NetBSD 8.1 October 20, 2011 NetBSD 8.1
You can also request any man page by name and (optionally) by section: