MOUNT_PSSHFS(8) NetBSD System Manager's Manual MOUNT_PSSHFS(8)
mount_psshfs -- sshfs implementation for puffs
mount_psshfs [options] user@host[:path] mount_point
The mount_psshfs utility can be used to mount a file system using the ssh sftp subprotocol, making a remote directory hierarchy appear in the local directory tree. This functionality is commonly known as sshfs. The mandatory parameters are the target host name and local mount point. The target host parameter can optionally contain a username whose creden- tials will be used by the remote sshd, and a relative or absolute path for the remote mount point's root. If no user is given, the credentials of the user issuing the mount command are used. If no path is given, the user's home directory on the remote machine will be used. The following command line options are available: -e Makes the mounted file system NFS exportable. If this option is used, it is very important to understand that mount_psshfs can not provide complete support for NFS due to the limitations in the back- end. Files are valid only for the time that mount_psshfs is running and in the event of e.g. a server crash, all client retries to access files will fail. -F configfile Pass a configuration file to ssh(1). This will make it ignore the system-wide /etc/ssh/ssh_config configuration file and use configfile instead of ~/.ssh/config. -o [no]option This flag can be used to give standard mount options and options to puffs. -O sshopt=value Pass an option to ssh(1), for example -O Port=22. For a list of valid options, see ssh_config(5). -p Preserve connection. This option makes mount_psshfs to try to reconnect to the server if the connection fails. The option is very experimental and does not preserve open files or retry current requests and should generally only be used if the trade-offs are well understood. -r max_reads Limits maximum outstanding read requests for each node to max_reads. This can be used to improve interactive performance on low-bandwidth links when also performing bulk data reads. -s This flag can be used to make the program stay on top. The default is to detach from the terminal and run in the background. -t timeout By default mount_psshfs caches directory contents and node attributes for 30 seconds before re-fetching from the server to check if anything has changed on the server. This option is used to adjust the timeout period to timeout seconds. A value 0 means the cache is never valid and -1 means it is valid indefinitely. It is possible to force a re-read regardless of timeout status by sending SIGHUP to the mount_psshfs process. Note: the file system will still free nodes when requested by the kernel and will lose all cached information in doing so. How fre- quently this happens depends on system activity and the total number of available vnodes in the system (kern.maxvnodes).
The following example illustrates how to mount the directory /usr on server bigiron as user abc on local directory /mnt with ssh transport compression enabled: mount_psshfs -O Compression=yes abc@bigiron:/usr /mnt It is possible to use fstab(5) for psshfs mounts, with SSH public key authentication: abc@bigiron:/usr /mnt psshfs rw,noauto,-O=BatchMode=yes,-O=IdentityFile=/root/.ssh/id_rsa,-t=-1
sftp(1), puffs(3), puffs(4), fstab(5), ssh_config(5), mount(8), sshd(8)
The mount_psshfs utility first appeared in NetBSD 5.0.
Permissions are not handled. Do not expect the file system to behave except for a single user. NetBSD 5.0_RC4 September 6, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: