MOUNT_PROCFS(8) NetBSD System Manager's Manual MOUNT_PROCFS(8)
mount_procfs -- mount the process file system
mount_procfs [-o options] /proc mount_point
The mount_procfs command attaches an instance of the process namespace to the global filesystem namespace. The conventional mount point is /proc. The directory specified by mount_point is converted to an absolute path before use. This command is normally executed by mount(8) at boot time. The options are as follows: -o nolinux Do not support nodes which are not part of the original procfs implementation but have been added for compatibility with the Linux procfs namespace. See FILES for more information. The root of the process filesystem contains an entry for each active process. These processes are visible as a directory whose name is the process' pid. In addition, the special entries curproc and self refer- ence the current process. The self symlink appears for compatibility with the Linux procfs implementation. Each directory contains several files. cmdline This file is readonly and returns null-terminated strings corre- sponding to the process' command line arguments. For a system or zombie process, this file contains only a string with the name of the process. ctl a writeonly file which supports a variety of control operations. Control commands are written as strings to the ctl file. The control commands are: attach stops the target process and arranges for the sending process to become the debug control process. detach continue execution of the target process and remove it from control by the debug process. run continue running the target process until a signal is delivered, a breakpoint is hit, or the target process exits. step single step the target process, with no signal delivery. wait wait for the target process to stop. The target process must be stopped before any of the run, step, or signal commands are allowed. The string can also be the name of a signal, lower case and with- out the SIG prefix, in which case that signal is delivered to the process (see sigaction(2)). cwd A symbolic link that points to the current working directory of the process. If the target process's current working directory is not available or is not at or below the current process's root directory, this link will point to ``/''. fd/# File descriptors which can be accessed through the file system. See fd(4) for more information. file A reference to the vnode from which the process text was read. This can be used to gain access to the process' symbol table, or to start another copy of the process. map A map of the process' virtual memory. maps A map of the process' virtual memory in a form like the proc filesystem as implemented in Linux. Note that the paths corre- sponding to file backed mappings will not be present unless the kernel was built with the NAMECACHE_ENTER_REVERSE option. mem The complete virtual memory image of the process. Only those addresses which exist in the process can be accessed. Writes to this file modify the process. Writes to the text segment nor- mally remain private to the process, since the text segment is mapped with MAP_PRIVATE; however, this is not guaranteed. note Not implemented. notepg Not implemented. regs Allows read and write access to the process' register set. This file contains a binary data structure struct regs defined in <machine/reg.h>. regs can only be written when the process is stopped. fpregs The floating point registers as defined by struct fpregs in <machine/reg.h>. fpregs is only implemented on machines which have distinct general purpose and floating point register sets. root A symbolic link that points to the root directory of the process. If the target process's root directory is not available or is not at or below the current process's root directory, this link will point to ``/''. status The process status. This file is readonly and returns a single line containing multiple space-separated fields as follows: + command name + process id + parent process id + process group id + session id + major,minor of the controlling terminal, or -1,-1 if there is no controlling terminal. + a list of process flags: ctty if there is a controlling ter- minal, sldr if the process is a session leader, noflags if neither of the other two flags are set. + the process start time in seconds and microseconds, comma separated. + the user time in seconds and microseconds, comma separated. + the system time in seconds and microseconds, comma separated. + the wait channel message + the process credentials consisting of the effective user id and the list of groups (whose first member is the effective group id) all comma separated. In a normal debugging environment, where the target is fork/exec'd by the debugger, the debugger should fork and the child should stop itself (with a self-inflicted SIGSTOP for example). The parent should issue a wait and then an attach command via the appropriate ctl file. The child process will receive a SIGTRAP immediately after the call to exec (see execve(2)).
/proc/# /proc/#/cmdline /proc/#/ctl /proc/#/cwd /proc/#/exe /proc/#/file /proc/#/fpregs /proc/#/map /proc/#/maps /proc/#/mem /proc/#/note /proc/#/notepg /proc/#/regs /proc/#/root /proc/#/status /proc/curproc /proc/self If the linux mount option is used, the following files are also avail- able: /proc/#/stat /proc/cpuinfo /proc/devices /proc/meminfo /proc/mounts /proc/uptime
mount(2), sigaction(2), unmount(2)
The mount_procfs utility first appeared in 4.4BSD.
This filesystem may not be NFS-exported since most of the functionality of procfs requires that state be maintained. NetBSD 5.1 February 24, 2009 NetBSD 5.1
You can also request any man page by name and (optionally) by section: