MOPD(8) NetBSD System Manager's Manual MOPD(8)
mopd -- Maintenance Operations Protocol (MOP) Loader Daemon
mopd [-adf] [-s mopdir] [interface] [...]
mopd services DEC Maintenance Operations Protocol (MOP) Load requests on the Ethernet connected to interface or all interfaces if -a option is given. In a load request received by mopd a filename can be given by the client. This is the normal case for terminal servers. If a filename isn't in the client load request mopd must know what image to load. Upon receiving a request, mopd checks if the requested file exists in /tftpboot/mop (unless the -s option is given, see below) the filename is normally uppercase and with an extension of .SYS. If the filename isn't given, the ethernet address of the target is used as filename, e.g. 08002b09f4de.SYS and it might be a soft link to another file. mopd supports two kinds of files. The first type that is check is if the file is in a.out(5) format. If not, a couple of Digital's formats are checked. In normal operation, mopd forks a copy of itself and runs in the back- ground. Anomalies and errors are reported via syslog(3).
-a Listen on all the Ethernets attached to the system. If -a is omitted, an interface must be specified. -d Run in debug mode, with all the output to stdout. The process will run in the foreground. -f Run in the foreground. -s Change the directory to look for files in from /tftpboot/mop to mopdir.
mopd automatically appends an upper case .SYS to the filename provided by the client. The typical client sends the requested file name in upper case.
mopchk(1), mopcopy(1), mopprobe(1), moptrace(1), bpf(4) DECnet Digital Network Architecture Phase IV, Maintenance Operations Functional Specification V3.0.0, AA-X436A-TK. DECnet Digital Network Architecture, Maintenance Operations Protocol Functional Specification V4.0.0, EK-DNA11-FS-001.
Mats O Jansson <firstname.lastname@example.org> NetBSD 8.1 January 23, 2004 NetBSD 8.1
You can also request any man page by name and (optionally) by section: