MFI(4) NetBSD Kernel Interfaces Manual MFI(4)
mfi -- LSI Logic & Dell MegaRAID SAS RAID controller
mfi* at pci? dev ? function ?
The mfi driver provides support for the MegaRAID SAS family of RAID con- trollers, including: - Dell PERC 5/e, PERC 5/i, PERC 6/e, PERC 6/i - Intel RAID Controller SRCSAS18E, SRCSAS144E - LSI Logic MegaRAID SAS 8208ELP, MegaRAID SAS 8208XLP, MegaRAID SAS 8300XLP, MegaRAID SAS 8308ELP, MegaRAID SAS 8344ELP, MegaRAID SAS 8408E, MegaRAID SAS 8480E, MegaRAID SAS 8888ELP, MegaRAID SAS 8880EM2 These controllers support RAID 0, RAID 1, RAID 5, RAID 10, and RAID 50 using either SAS or SATA II drives. Although the controllers are actual RAID controllers, the driver makes them look just like SCSI controllers. All RAID configuration is done through the controllers' BIOSes. mfi supports monitoring of the logical disks in the controller through the bioctl(8) and envstat(8) commands.
The mfi driver is able to send events to powerd(8) if a logical drive in the controller is not online. The state-changed event will be sent to the /etc/powerd/scripts/sensor_drive script when such condition happens.
intro(4), pci(4), scsi(4), sd(4), bioctl(8), envstat(8), powerd(8)
The mfi driver first appeared in NetBSD 4.0. NetBSD 5.0_RC4 February 29, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: