LM(4) NetBSD Kernel Interfaces Manual LM(4)
lm -- National Semiconductor LM78, LM79 and compatible hardware monitors
lm0 at isa? port 0x280 lm1 at isa? port 0x290 lm2 at isa? port 0x310 lm3 at isa? port 0xa00 lm0 at pnpbios0 index ? lm0 at iic? addr 0x2e
The lm driver provides support for the National Semiconductor LM series hardware monitors and register compatible chips to be used with the envsys(4) API. Most supported devices possess 11 sensors: Sensor Units Typical Use IN0 uV DC Core voltage IN1 uV DC unknown IN2 uV DC +3.3V IN3 uV DC +5V IN4 uV DC +12V IN5 uV DC -12V IN6 uV DC -5V Temp uK Motherboard Temperature Fan0 RPM Fan Fan1 RPM Chassis Fan Fan2 RPM Fan for some devices (most Winbond devices) sensor names and numbers will be different. Due to hardware limitations, fresh sensor data is only available every 2 seconds.
Chips supported by the lm driver include: National Semiconductor LM78, LM78-J, LM79 and LM81. Winbond W83627HF, W83627THF, W83627EHF, W83627DHG, W83637HF, W83697HF, W83781D, W83782D, W83783S, W83791D, W83791SD and W83792D. ASUS AS99127F.
The lm device appeared in NetBSD 1.5.
Interrupt support is unimplemented. There are currently no known pnpbios IDs assigned to LM chips. NetBSD 5.1 October 13, 2008 NetBSD 5.1
You can also request any man page by name and (optionally) by section: