IRFRAME(4) NetBSD Kernel Interfaces Manual IRFRAME(4)
irframe -- IrDA frame level driver
irframe* at oboe? irframe* at udsir? irframe* at uirda? irframe* at ustir? pseudo-device irframetty #include <dev/irdaio.h>
The irframe driver provides support for IrDA frame level transmission. It does not contain the IrDA protocol stack per se, but the stack can be built on top of the irframe driver. Access to frames is via the read(2) and write(2) system calls. Each write constitutes one frame, and each read yields one frame. The poll(2) system call can be used to check for availability of frames. There are also a number of ioctl(2) calls to manipulate the device: IRDA_RESET_PARAMS Reset the parameters set by IRDA_SET_PARAMS. IRDA_SET_PARAMS (struct irda_params) Set the speed, extra beginning of frame bytes, and maximum frame size. IRDA_GET_SPEEDMASK (int) Get the set of allowable speeds. IRDA_GET_TURNAROUNDMASK (int) Get the set of allowable turn around times.
cir(4), irframetty(4), oboe(4), uirda(4), ustir(4) comms/birda package
The irframe driver appeared in NetBSD 1.6. NetBSD 9.0 December 2, 2001 NetBSD 9.0
You can also request any man page by name and (optionally) by section: