IP6ADDRCTL(8) NetBSD System Manager's Manual IP6ADDRCTL(8)
ip6addrctl -- configure address selection policy for IPv6 and IPv4
ip6addrctl [show] ip6addrctl add prefix precedence label ip6addrctl delete prefix ip6addrctl flush ip6addrctl install configfile
The ip6addrctl utility manages the policy table of source and destination address selection for outgoing IPv4 and IPv6 packets. When ip6addrctl is invoked without an argument or with a single argument show, it prints the content of the policy table currently installed in the kernel. To modify the table, the following operations are available: add prefix precedence label Add a policy entry. The prefix argument is an IPv6 prefix, which is a key for the entry. An IPv4 prefix should be specified with an IPv6 prefix using an IPv4-mapped IPv6 address. The precedence and label arguments are decimal numbers, which specify the prece- dence and label values for the entry, respectively. This opera- tion should be performed without an existing entry for the pre- fix. delete prefix Delete a policy entry specified by prefix, which should be an IPv6 prefix. A corresponding entry for the prefix should have already been installed. flush Delete all existing policy entries in the kernel. install configfile Install policy entries from a configuration file named configfile. The configuration file should contain a set of pol- icy entries. Each entry is specified in a single line which con- tains an IPv6 prefix, a decimal precedence value, and a decimal label value, separated with white space or tab characters. In the configuration file, lines beginning with the pound-sign (`#') are comments and are ignored.
The ip6addrctl utility exits 0 on success, and >0 if an error occurs.
Richard Draves, Default Address Selection for IPv6, RFC 3484.
The ip6addrctl utility first appeared in the KAME IPv6 protocol stack kit. The original command name was addrselect, but it was then renamed to the current one so that the name would describe its function well. NetBSD 9.0 September 25, 2001 NetBSD 9.0
You can also request any man page by name and (optionally) by section: