IOASIC(4) NetBSD Kernel Interfaces Manual IOASIC(4)
ioasic -- baseboard IO control ASIC for DEC TURBOchannel systems
ioasic0 at tc? slot ? offset ?
The ioasic driver provides support for the DEC proprietary IOCTL ASIC found on all DEC TURBOchannel machines with MIPS (DECstation 5000 series, excluding the 5000/200) and Alpha (3000-series) processors. On these machines (including the 5000/200), all baseboard devices should be con- figured as children of the ioasic device. The ioasic provides hardware DMA channels and interrupt support for sev- eral baseboard devices, including one asc SCSI device with a scat- ter/gather DMA channel, an mc146818-compatible mcclock, an Am7930 audio device bba, one or two zs two-port serial devices, and a AMD 7990 LANCE le Ethernet interface. The ioasic is also used for the floppy-disc drive and audio/ISDN hardware on the Personal DECstation and audio-equipped TURBOchannel Alphas, where the ioasic hardware provides a scatter-gather DMA channel between the 16-bit device and the 32-bit tc DMA address space. Support for scatter-gather DMA eliminates the need for additional copy- ing. A baseboard asc SCSI adaptor attached to an ioasic will give slightly better performance than its tc counterpart.
asc(4), bba(4), intro(4), le(4), mcclock(4), tc(4), zs(4)
The ioasic driver first appeared in NetBSD 1.1, derived from DECstation boot-time configuration code in 4.4BSD.
The DECstation 5000/200 does not actually have an IOASIC chip, but for consistency it must be configured as if it did. NetBSD 9.0 September 12, 2007 NetBSD 9.0
You can also request any man page by name and (optionally) by section: