INTRCTL(8) NetBSD System Manager's Manual INTRCTL(8)
intrctl -- program to control interrupts
intrctl command [options]
The intrctl command can be used to control and inspect the state of interrupts in the system. The first argument, command, specifies the action to take. Valid com- mands are: affinity -c cpu_index -i intrid set an intrid interrupt's affinity to cpu_index. intr -c cpu_index enable to set an interrupt's affinity to cpu_index. If cpu_index is already enabled, this command has no effect. list [-cz] [-w wait] for each intrid in the system, display interrupt counts per CPU. The intrid is an interrupt name such as "ioapic0 pin 22" for x86. If -c is specified, display compact list with total counts per interrupt, and CPU affinity as comma sepa- rated list of CPU indexes. If -w is specified then intrctl display the data contin- uously with a wait seconds delay between each iteration. If -z is specified then rows with all CPUs having zero interrupts will be skipped. nointr -c cpu_index disable to set an interrupt's affinity to cpu_index. If cpu_index is already disabled, this command has no effect.
intrctl first appeared in NetBSD 8.0.
Kengo NAKAHARA <knakahara@NetBSD.org> NetBSD 9.0 September 23, 2019 NetBSD 9.0
You can also request any man page by name and (optionally) by section: