INSTALLBOOT(8) NetBSD System Manager's Manual INSTALLBOOT(8)
installboot -- install disk bootstrap software
installboot [-fnv] [-B s2bno] [-b s1bno] [-m machine] [-o options] [-t fstype] filesystem primary [secondary] installboot -c [-fnv] [-m machine] [-o options] [-t fstype] filesystem installboot -e [-fnv] [-m machine] [-o options] bootstrap
The installboot utility installs and removes NetBSD disk bootstrap soft- ware into a file system. installboot can install primary into filesystem, or disable an existing bootstrap in filesystem. One some architectures the options of an existing installed bootstrap, or those of a bootstrap file can be changed. Generally, NetBSD disk bootstrap software consists of two parts: a ``primary'' bootstrap program usually written into the disklabel area of the file system by installboot, and a ``secondary'' bootstrap program that usually resides as an ordinary file in the file system. When booting, the primary bootstrap program is loaded and invoked by the machine's PROM or BIOS. After receiving control of the system it loads and runs the secondary bootstrap program, which in turn loads and runs the kernel. The secondary bootstrap may allow control over various boot parameters passed to the kernel. Perform the following steps to make a file system bootable: 1. Copy the secondary bootstrap (usually /usr/mdec/boot.MACHINE or /usr/mdec/boot) to the root directory of the target file system. 2. Use installboot to install the primary bootstrap program (usually /usr/mdec/bootxx_FSTYPE) into filesystem. The following platforms do not require this step if the primary bootstrap already exists and the secondary bootstrap file is just being updated: alpha, amd64, amiga, i386, pmax, sparc64, and vax. The following platform does not require the first step since a sin- gle bootstrap file is used. The single bootstrap is installed like the primary bootstrap on other platforms: next68k. The options and arguments recognized by installboot are as follows: -B s2bno When hard-coding the blocks of secondary into primary, start from block s2bno instead of trying to determine the block numbers occupied by secondary by examining filesystem. If this option is supplied, secondary should refer to an actual secondary bootstrap (rather than the file name of the one present in filesystem) so that its size can be determined. -b s1bno Install primary at block number s1bno instead of the default location for the machine and file system type. [alpha, pmax, vax] -c Clear (remove) any existing bootstrap instead of installing one. -e Edit the options of an existing bootstrap. This can be use to change the options in bootxx_xxxfs files, raw disk parti- tions, and the pxeboot_ia32.bin file. [amd64, i386] -f Forces installboot to ignore some errors. -m machine Use machine as the target machine type. The default machine is determined from uname(3) and then MACHINE. The following machines are currently supported by installboot: alpha, amd64, amiga, ews4800mips, hp300, hp700, i386, landisk, macppc, news68k, newsmips, next68k, pmax, sparc, sparc64, sun2, sun3, vax, x68k -n Do not write to filesystem. -o options Machine specific installboot options, comma separated. Supported options are (with the machines for they are valid in brackets): alphasum [alpha] Recalculate and restore the Alpha checksum. This is the default for NetBSD/alpha. append [alpha, pmax, vax] Append primary to the end of filesystem, which must be a regular file in this case. command=<boot command> [amiga] Modify the default boot command line. console=<console name> [amd64, i386] Set the console device, <con- sole name> must be one of: pc, com0, com1, com2, com3, com0kbd, com1kbd, com2kbd or com3kbd. ioaddr=<ioaddr> [amd64, i386] Set the IO address to be used for the console serial port. Defaults to the IO address used by the system BIOS for the specified port. keymap=<keymap> [amd64, i386] Set a boot time keyboard trans- lation map. Each character in <keymap> will be replaced by the one following it. For example, an argument of ``zyz'' would swap the lowercase letters `y' and `z'. password=<password> [amd64, i386] Set the password which must be entered before the boot menu can be accessed. resetvideo [amd64, i386] Reset the video before booting. speed=<baud rate> [amd64, i386] Set the baud rate for the serial console. If a value of zero is speci- fied, then the current baud rate (set by the BIOS) will be used. sunsum [alpha, pmax, vax] Recalculate and restore the Sun and NetBSD/sparc compatible checksum. Note: The existing NetBSD/sparc disklabel should use no more than 4 partitions. timeout=<seconds> [amd64, i386] Set the timeout before the automatic boot begins to the given number of seconds. -t fstype Use fstype as the type of filesystem. The default operation is to attempt to auto-detect this setting. The following file system types are currently supported by installboot: ffs BSD Fast File System. raid Mirrored RAIDframe File System. raw `Raw' image. Note: if a platform needs to hard- code the block offset of the secondary bootstrap, it cannot be searched for on this file system type, and must be provided with -B s2bno. -v Verbose operation. filesystem The path name of the device or file system image that installboot is to operate on. It is not necessary for filesystem to be a currently mounted file system. primary The path name of the ``primary'' boot block to install. The path name must refer to a file in a file system that is cur- rently mounted. secondary The path name of the ``secondary'' boot block, relative to the root of the file system in the device or image specified by the filesystem argument. Note that this may refer to a file in a file system that is not mounted. Most systems require secondary to be in the ``root'' directory of the file system, so the leading ``/'' is not necessary on secondary. Only certain combinations of platform (-m machine) and file system type (-t fstype) require that the name of the sec- ondary bootstrap is supplied as secondary, so that informa- tion such as the disk block numbers occupied by the secondary bootstrap can be stored in the primary bootstrap. These are: Platform File systems macppc ffs, raw news68k ffs, raw newsmips ffs, raw sparc ffs, raid, raw sun2 ffs, raw sun3 ffs, raw installboot exits 0 on success, and >0 if an error occurs.
installboot uses the following environment variables: MACHINE Default value for machine, overriding the result from uname(3).
Most NetBSD ports will contain variations of the following files: /usr/mdec/bootxx_FSTYPE Primary bootstrap for file system type FSTYPE. Installed into the bootstrap area of the file system by installboot. /usr/mdec/bootxx_fat16 Primary bootstrap for MS-DOS FAT16 file sys- tems. This differs from bootxx_msdos in that it doesn't require the filesystem to have been initialised with any `reserved sectors'. It also uses the information in the `Boot Parameter Block' to get the media and filesytem properties. /usr/mdec/bootxx_ffsv1 Primary bootstrap for FFSv1 file systems (the "traditional" NetBSD file system). /usr/mdec/bootxx_ffsv2 Primary bootstrap for FFSv2 file systems. /usr/mdec/bootxx_lfsv1 Primary bootstrap for LFSv1 file systems. /usr/mdec/bootxx_lfsv2 Primary bootstrap for LFSv2 file systems (the default LFS version). /usr/mdec/bootxx_msdos Primary bootstrap for MS-DOS FAT file systems. /usr/mdec/bootxx_ustarfs Primary bootstrap for TARFS boot images. This is used by various install media. /usr/mdec/boot.MACHINE Secondary bootstrap for machine type MACHINE. This should be installed into the file system before installboot is run. /usr/mdec/boot Synonym for /usr/mdec/boot.MACHINE /boot.MACHINE Installed copy of secondary bootstrap for machine type MACHINE. /boot Installed copy of secondary bootstrap. Searched for by the primary bootstrap if /boot.MACHINE is not found. NetBSD/macppc files /usr/mdec/bootxx NetBSD/macppc primary bootstrap. /usr/mdec/ofwboot NetBSD/macppc secondary bootstrap. /ofwboot Installed copy of NetBSD/macppc secondary boot- strap. NetBSD/next68k files /usr/mdec/boot NetBSD/next68k bootstrap. NetBSD/sparc64 files /usr/mdec/bootblk NetBSD/sparc64 primary bootstrap. /usr/mdec/ofwboot NetBSD/sparc64 secondary bootstrap. /ofwboot Installed copy of NetBSD/sparc64 secondary bootstrap.
common Verbosely install the Berkeley Fast File System primary bootstrap on to disk `sd0': installboot -v /dev/rsd0c /usr/mdec/bootxx_ffs Note: the ``whole disk'' partition (c on some ports, d on others) is used here, since the a partition probably is already opened (mounted as /), so installboot would not be able to access it. Remove the primary bootstrap from disk `sd1': installboot -c /dev/rsd1c NetBSD/amiga Modify the command line to change the default from "netbsd -ASn2" to "netbsd -S": installboot -m amiga -o command="netbsd -S" /dev/rsd0a /usr/mdec/bootxx_ffs NetBSD/ews4800mips Install the System V Boot File System primary bootstrap on to disk `sd0', with the secondary bootstrap `/boot' already present in the SysVBFS par- tition on the disk: installboot /dev/rsd0c /usr/mdec/bootxx_bfs NetBSD/i386 and NetBSD/amd64 Install new boot blocks on an existing mounted root file system on `wd0', setting the timeout to five seconds, after copying a new secondary boot- strap: cp /usr/mdec/boot /boot installboot -v -o timeout=5 /dev/rwd0a /usr/mdec/bootxx_ffsv1 Create a bootable CD-ROM with an ISO9660 file system for an i386 system with a serial console: mkdir cdrom cp sys/arch/i386/compile/mykernel/netbsd cdrom/netbsd cp /usr/mdec/boot cdrom/boot cp /usr/mdec/bootxx_cd9660 bootxx installboot -o console=com0,speed=19200 -m i386 -e bootxx makefs -t cd9660 -o 'bootimage=i386;bootxx,no-emul-boot' boot.iso cdrom Create a bootable floppy disk with an FFSv1 file system for a small cus- tom kernel (note: bigger kernels needing multiple disks are handled with the ustarfs file system): newfs -s 1440k /dev/rfd0a Note: Ignore the warnings that newfs(8) displays; it can not write a disklabel, which is not a problem for a floppy disk. mount /dev/fd0a /mnt cp /usr/mdec/boot /mnt/boot gzip -9 < sys/arch/i386/compile/mykernel/netbsd > /mnt/netbsd.gz umount /mnt installboot -v /dev/rfd0a /usr/mdec/bootxx_ffsv1 Create a bootable FAT file system on `wd1a', which should have the same offset and size as a FAT primary partition in the Master Boot Record (MBR): newfs_msdos -r 16 /dev/rwd1a Notes: The -r 16 is to reserve space for the primary boot- strap. newfs_msdos(8) will display an ``MBR type'' such as `1', `4', or `6'; the MBR partition type of the appropriate primary partition should be changed to this value. mount -t msdos /dev/wd1a /mnt cp /usr/mdec/boot /mnt/boot cp path/to/kernel /mnt/netbsd umount /mnt installboot -t raw /dev/rwd1a /usr/mdec/bootxx_msdos Make the existing FAT16 filesystem on `sd0e' bootable. This can be used to make USB memory bootable provided it has 512 byte sectors and that the manufacturer correctly initialised the file system. mount -t msdos /dev/sd0e /mnt cp /usr/mdec/boot /mnt/boot cp path/to/kernel /mnt/netbsd umount /mnt installboot /dev/rsd0e /usr/mdec/bootxx_fat16 It may also be necessary to use fdisk to make the device itself bootable. Switch the existing installed bootstrap to use a serial console without reinstalling or altering other options such as timeout. installboot -e -o console=com0 /dev/rwd0a NetBSD/macppc Note the installboot utility is only required for macppc machines with OpenFirmware version 2 to boot. OpenFirmware 3 cannot load bootblocks specified in the Apple partition map. Install the Berkeley Fast File System primary bootstrap on to disk `wd0': installboot /dev/rwd0c /usr/mdec/bootxx /ofwboot The secondary NetBSD/macppc bootstrap is located in /usr/mdec/ofwboot. The primary bootstrap requires the raw ofwboot for the secondary boot- strap, not ofwboot.xcf, which is used for the OpenFirmware to load ker- nels. NetBSD/next68k Install the bootstrap on to disk `sd0': installboot /dev/rsd0c /usr/mdec/boot NetBSD/pmax Install the Berkeley Fast File System primary bootstrap on to disk `sd0': installboot /dev/rsd0c /usr/mdec/bootxx_ffs NetBSD/pmax requires that this file system starts at block 0 of the disk. Install the ISO 9660 primary bootstrap in the file /tmp/cd-image: installboot -m pmax /tmp/cd-image /usr/mdec/bootxx_cd9660 Make an ISO 9660 filesystem in the file /tmp/cd-image and install the ISO 9660 primary bootstrap in the filesystem, where the source directory for the ISO 9660 filesystem contains a kernel, the primary bootstrap bootxx_cd9660 and the secondary bootstrap boot.pmax: mkisofs -o /tmp/cd-image -a -l -v iso-source-dir ... 48 51 iso-source-dir/bootxx_cd9660 ... installboot -b `expr 48 \* 4` /tmp/cd-image /usr/mdec/bootxx_cd9660 NetBSD/sparc Install the Berkeley Fast File System primary bootstrap on to disk `sd0', with the secondary bootstrap `/boot' already present: installboot /dev/rsd0c /usr/mdec/bootxx /boot NetBSD/sparc64 Install the Berkeley Fast File System primary bootstrap on to disk `wd0': installboot /dev/rwd0c /usr/mdec/bootblk The secondary NetBSD/sparc64 bootstrap is located in /usr/mdec/ofwboot. NetBSD/sun2 and NetBSD/sun3 Install the Berkeley Fast File System primary bootstrap on to disk `sd0', with the secondary bootstrap `/boot' already present: installboot /dev/rsd0c /usr/mdec/bootxx /boot
uname(3), boot(8), disklabel(8), fdisk(8), pxeboot(8)
This implementation of installboot appeared in NetBSD 1.6.
The machine independent portion of this implementation of installboot was written by Luke Mewburn. The following people contributed to the various machine dependent back-ends: Simon Burge (pmax), Chris Demetriou (alpha), Matthew Fredette (sun2, sun3), Matthew Green (sparc64), Ross Harvey (alpha), Michael Hitch (amiga), Paul Kranenburg (sparc), David Laight (i386), Christian Limpach (next68k), Luke Mewburn (macppc), Matt Thomas (vax), Izumi Tsutsui (news68k, newsmips), and UCHIYAMA Yasushi (ews4800mips).
There are not currently primary bootstraps to support all file systems types which are capable of being the root file system. If a disk has been converted from FFS to RAID without the contents of the disk erased, then the original FFS installation may be auto-detected instead of the RAID installation. In this case, the -t raid option must be provided. NetBSD/alpha The NetBSD/alpha primary bootstrap program can only load the secondary bootstrap program from file systems starting at the beginning (block 0) of disks. Similarly, the secondary bootstrap program can only load ker- nels from file systems starting at the beginning of disks. The size of primary bootstrap programs is restricted to 7.5KB, even though some file systems (e.g., ISO 9660) are able to accommodate larger ones. NetBSD/hp300 The disk must have a boot partition large enough to hold the bootstrap code. Currently the primary bootstrap must be a LIF format file. NetBSD/i386 and NetBSD/amd64 The bootstrap must be installed in the NetBSD partition that starts at the beginning of the mbr partition. If that is a valid filesystem and contains the /boot program then it will be used as the root filesystem, otherwise the `a' partition will be booted. The size of primary bootstrap programs is restricted to 8KB, even though some file systems (e.g., ISO 9660) are able to accommodate larger ones. NetBSD/macppc Due to restrictions in installboot and the secondary bootstrap implemen- tation, file systems where kernels exist must start at the beginning of disks. Currently, installboot doesn't recognize an existing Apple partition map on the disk and always writes a faked map to make disks bootable. The NetBSD/macppc bootstrap program can't load kernels from FFSv2 parti- tions. NetBSD/next68k The size of bootstrap programs is restricted to the free space before the file system at the beginning of the disk minus 8KB. NetBSD/pmax The NetBSD/pmax secondary bootstrap program can only load kernels from file systems starting at the beginning of disks. The size of primary bootstrap programs is restricted to 7.5KB, even though some file systems (e.g., ISO 9660) are able to accommodate larger ones. NetBSD/sun2 and NetBSD/sun3 The NetBSD/sun2 and NetBSD/sun3 secondary bootstrap program can only load kernels from file systems starting at the beginning of disks. NetBSD/vax The NetBSD/vax secondary bootstrap program can only load kernels from file systems starting at the beginning of disks. The size of primary bootstrap programs is restricted to 7.5KB, even though some file systems (e.g., ISO 9660) are able to accommodate larger ones. NetBSD 5.1 October 12, 2008 NetBSD 5.1
You can also request any man page by name and (optionally) by section: