IMCSMB(4) NetBSD Kernel Interfaces Manual IMCSMB(4)
imcsmb -- Intel integrated Memory Controller (iMC) SMBus controller driver
imc* at pci? dev? func? imcsmb* at imc? iic* at i2cbus? Alternatively, to load the driver as a module at boot time, place the following line in boot.cfg(5): load=imcsmb or add the following line to your /etc/modules file: imcsmb
The imcsmb driver provides iic(4) support for the SMBus controller func- tionality in the integrated Memory Controllers (iMCs) embedded in Intel Sandybridge-Xeon, Ivybridge-Xeon, Haswell-Xeon, and Broadwell-Xeon CPUs. Each CPU implements one or more iMCs, depending on the number of cores; each iMC implements two SMBus controllers (iMC-SMBs). The iMC-SMBs are used by the iMCs to read configuration information from the DIMMs during POST. They may also be used, by motherboard firmware or a BMC, to moni- tor the temperature of the DIMMs. The iMC-SMBs are not general-purpose SMBus controllers. By their nature, they are only ever attached to DIMMs, so they implement only the SMBus operations needed for communicating with DIMMs. Specifically: - READB - READW - WRITEB - WRITEW A more detailed discussion of the hardware and driver architecture can be found at the top of sys/dev/imcsmb/imc.c.
As mentioned above, firmware might use the iMC-SMBs to read DIMM tempera- tures. The public iMC documentation does not describe any sort of coor- dination mechanism to prevent requests from different sources -- such as the motherboard firmware, a BMC, or the operating system -- from inter- fering with each other. Therefore, it is highly recommended that developers contact the mother- board vendor for any board-specific instructions on how to disable and re-enable DIMM temperature monitoring. DIMM temperature monitoring should be disabled before returning from imcsmb_pci_request_bus(), and re-enabled before returning from imcsmb_pci_release_bus(). The driver includes comments to that effect at the appropriate locations. The driver has been tested and shown to work, with only that type of modification, on certain motherboards from Intel. (Unfortunately, those modifications were based on material covered under a non-disclosure agreement, and therefore are not included in this driver.) The driver has also been tested and shown to work as-is on var- ious motherboards from SuperMicro and ASUS. Because of the above, the imcsmb driver is not included in the default GENERIC kernel. In order to use the imcsmb driver, you must compile a custom kernel, or load the driver using modload(8). The iic(4) driver will connect to the i2cbus instances created by imcsmb.
The imcsmb driver first appeared in FreeBSD 12.0. It was later ported to NetBSD 9.0.
The imcsmb driver was originally written for Panasas by Joe Kloss. It was substantially refactored, and this manual page was written, by Ravi Pokala <firstname.lastname@example.org>. It was adapted to NetBSD by Paul Goyette <pgoyette@NetBSD.org>. NetBSD 9.0 February 28, 2018 NetBSD 9.0
You can also request any man page by name and (optionally) by section: