HYTHYGTEMP(4) NetBSD Kernel Interfaces Manual HYTHYGTEMP(4)
hythygtemp -- Driver for IST-AG HYT-221/271/939 sensor chip via I2C bus
hythygtemp* at iic? addr 0x28
The hythygtemp driver provides measurements from the HYT-221/271/939 humidity/temperature sensors via the envsys(4) framework. The hythygtemp addr argument selects the address at the iic(4) bus. The sampling inter- val can be changed through the sysctl(8) node hw.hythygtemp0.interval. The sensor chips can be reconfigured to respond to other addresses than the default value of 0x28 by external utilities, like for example the pkgsrc/sysutils/hytctl package.
The following sysctl(3) variables are provided: hw.hythygtemp0.interval Defines the sensor's sampling interval in seconds. It defaults to 50 seconds.
envsys(4), iic(4), envstat(8), sysctl(8)
The hythygtemp driver first appeared in NetBSD 7.0.
The hythygtemp driver was written by Frank Kardel <kardel@NetBSD.org> and Frank Wille <phx@NetBSD.org>. NetBSD 9.0 September 9, 2015 NetBSD 9.0
You can also request any man page by name and (optionally) by section: