HTTPD(8) NetBSD System Manager's Manual HTTPD(8)
httpd -- hyper text transfer protocol version 1.1 daemon
httpd [-HVXbenrus] [-C suffix cgihandler] [-I port] [-M suffix type encoding encoding11] [-S server_software] [-c cgibin] [-i address] [-p pubdir] [-v virtualroot] [-x index] [-Z cert privkey] slashdir [myname]
The httpd program reads a HTTP request from the standard input, and sends a reply to the standard output. Besides ~user translation and virtual hosting support (see below), all file requests are from slashdir direc- tory. The server uses myname as its name, which defaults to the local hostname, obtained from gethostname(3) (but see the -v option for virtual hosting.) httpd is designed to be small, simple and relatively feature- less, hopefully increasing its security.
The following options are available: -b This option enables daemon mode, where httpd detaches from the current terminal, running in the background and servicing HTTP requests. -C suffix cgihandler This option adds a new CGI handler program for a particular file type. The suffix should be any normal file suffix, and the cgihandler should be a full path to an interpreter. This option is the only way to enable CGI programs that exist out- side of the cgibin directory to be executed. Multiple -C options may be passed. -c cgibin This option enables the CGI/1.1 interface. The cgibin direc- tory is expected to contain the CGI programs to be used. httpd looks for URL's in the form of /cgi-bin/<scriptname> where <scriptname> is a valid CGI program in the cgibin direc- tory. In other words, all CGI URL's must begin with /cgi-bin/. Note that the CGI/1.1 interface is not available with ~user translation. -e This option causes httpd to not clear the environment when used with either the -t or -U options. -H This option causes directory index mode to hide files and directories that start with a period, except for ... Also see -X. -I port This option is only valid with the -b option. It causes port to use used as the port to bind daemon mode. The default is the ``http'' port. -i address This option is only valid with the -b option. It causes address to use used as the address to bind daemon mode. If otherwise unspecified, the address used to bind is derived from the myname, which defaults to the name returned by gethostname(3). -M suffix type encoding encoding11 This option adds a new entry to the table that converts file suffixes to content type and encoding. This option takes four additional arguments containing the file prefix, its ``Content-Type'', ``Content-Encoding'' and ``Content-Encoding'' for HTTP/1.1 connections, respectively. If any of these are a single ``-'' (dash), the empty string is used instead. Multiple -M options may be passed. -n This option stops httpd from doing IP address to name resolu- tion of hosts for setting the REMOTE_HOST variable before run- ning a CGI program. This option has no effect without the -c option. -p pubdir This option changes the default user directory for /~user/ translations from ``public_html'' to pubdir. -r This option forces pages besides the ``index.html'' (see the -X option) page to require that the Referrer: header be present and refer to this web server, otherwise a redirect to the ``index.html'' page will be returned instead. -S server_software This option sets the internal server version to server_software. -s This option forces logging to be set to stderr always. -t chrootdir When this option is used, httpd will chroot to the specified directory before answering requests. Every other path should be specified relative to the new root, if this option is used. Note that the current environment is normally replaced with an empty environment with this option, unless the -e option is also used. -U username This option causes httpd to switch to the user and the groups of username after initialization. This option, like -t above, causes httpd to clear the environment unless the -e option is given. -u This option enables the transformation of Uniform Resource Locators of the form /~user/ into the the directory ~user/public_html (but see the -p option above). -V This option sets the default virtual host directory to slashdir. If no directory exists in virtualroot for the request, then slashdir will be used. The default behaviour is to return 404 (Not Found.) -v virtualroot This option enables virtual hosting support. Directories in virtualroot will be searched for a matching virtual host name, when parsing the HTML request. If a matching name is found, it will be used as both the server's real name, [myname], and as the slashdir. See the EXAMPLES section for an example of using this option. -X This option enables directory indexing. A directory index will be generated only when the default file (i.e. index.html normally) is not present. -x index This option changes the default file read for directories from ``index.html'' to index. -Z certificate_path privatekey_path This option sets the path to the server certificate file and the private key file in pem format. It also causes httpd to start SSL mode. Note that in httpd versions 20031005 and prior that supported the -C and -M options, they took a single space-separated argument that was parsed. since version 20040828, they take multiple options (2 in the case of -C and 4 in the case of -M.)
As httpd uses inetd(8) by default to process incoming TCP connections for HTTP requests (but see the -b option), httpd has little internal network- ing knowledge. (Indeed, you can run it on the command line with little change of functionality.) A typical inetd.conf(5) entry would be: http stream tcp nowait:600 _httpd /usr/libexec/httpd httpd /var/www http stream tcp6 nowait:600 _httpd /usr/libexec/httpd httpd /var/www This would serve web pages from /var/www on both IPv4 and IPv6 ports. The :600 changes the requests per minute to 600, up from the inetd(8) default of 40. Using the NetBSD inetd(8), you can provide multiple IP-address based HTTP servers by having multiple listening ports with different configurations.
To configure set of virtual hosts, one would use an inetd.conf(5) entry like: http stream tcp nowait:600 _httpd /usr/libexec/httpd httpd -v /var/vroot /var/www and inside /var/vroot create a directory (or a symlink to a directory) with the same name as the virtual host, for each virtual host. Lookups for these names are done in a case-insensitive manner. To use httpd with PHP, one must use the -C option to specify a CGI han- dler for a particular file type. Typically this, this will be like: httpd -C .php /usr/pkg/bin/php /var/www
This server supports the HTTP/0.9, HTTP/1.0 and HTTP/1.1 standards. Sup- port for these protocols is very minimal and many optional features are not supported. httpd can be compiled without CGI support (NO_CGIBIN_SUPPORT), user transformations (NO_USER_SUPPORT), directory index support (NO_DIRINDEX_SUPPORT), daemon mode support (NO_DAEMON_MODE), and dynamic MIME content (NO_DYNAMIC_CONTENT), and SSL support (NO_SSL_SUPPORT) by defining the listed macros when building httpd.
HTTP BASIC AUTHORISATION
httpd has support for HTTP Basic Authorisation. If a file named .htpasswd exists in the directory of the current request, httpd will restrict access to documents in that directory using the RFC 2617 HTTP ``Basic'' authentication scheme. Note: This does not recursively protect any sub-directories. The .htpasswd file contains lines delimited with a colon containing user- names and passwords hashed with crypt(3), for example: heather:$1$pZWI4tH/$DzDPl63i6VvVRv2lJNV7k1 jeremy:A.xewbx2DpQ8I On NetBSD, the pwhash(1) utility may be used to generate hashed pass- words. While httpd distributed with NetBSD has support for HTTP Basic Authorisa- tion enabled by default, the portable distribution it is excluded. Com- pile httpd with ``-DDO_HTPASSWD'' on the compiler command line to enable this support. It may require linking with the crypt library, using ``-lcrypt''.
httpd looks for a couple of special files in directories that allow cer- tain features to be provided on a per-directory basis. In addition to the .htpasswd used by HTTP basic authorisation, if a .bzdirect file is found (contents are irrelevant) httpd will allow direct access even with the -r option. If a .bzredirect symbolic link is found, httpd will per- form a smart redirect to the target of this symlink. The target is assumed to live on the same server. If a .bzabsredirect symbolic link is found, httpd will redirect to the absolute url pointed to by this sym- link. This is useful to redirect to different servers.
httpd has support for SSLv2, SSLv3, and TLSv1 protocols that is included by default. It requires linking with the crypto and ssl library, using ``-lcrypto -lssl''. To disable SSL SUPPORT compile httpd with ``-DNO_SSL_SUPPORT'' on the compiler command line.
The httpd program was first written in perl, based on another perl http server called ``tinyhttpd''. It was then rewritten from scratch in perl, and then once again in C. It was known for many years as ``bozohttpd''. ``bozohttpd'' version 20060517 was integrated into NetBSD 5.0 as httpd. The focus has always been simplicity and security, with minimal features and regular code audits. This manual documents httpd version 20080303.
httpd was written by Matthew R. Green <email@example.com>. The large list of contributors includes: - Arnaud Lacombe <firstname.lastname@example.org> provided some clean up for memory leaks - Christoph Badura <email@example.com> provided Range: header support - Julian Coleman <firstname.lastname@example.org> provided an IPv6 bugfix - Chuck Cranor <email@example.com> provided cgi-bin support fixes, and more - Andrew Doran <firstname.lastname@example.org> provided directory indexing support - Per Ekman <email@example.com> provided a fix for a minor (non-security) buffer overflow condition - Zak Johnson <firstname.lastname@example.org> provided cgi-bin enhancements - Jun-ichiro itojun Hagino, KAME <email@example.com> provided initial IPv6 support - Martin Husemann <firstname.lastname@example.org> provided .bzabsredirect support - Roland Illig <email@example.com> provided some off-by-one fixes - Nicolas Jombart <firstname.lastname@example.org> provided fixes for HTTP basic autho- risation support - Thomas Klausner <email@example.com> provided many fixes and enhancements for the man page - Johnny Lam <firstname.lastname@example.org> provided man page fixes - Luke Mewburn <email@example.com> provided many various fixes, includ- ing cgi-bin fixes & enhancements, HTTP basic authorisation support and much code clean up - Jeremy C. Reed <firstname.lastname@example.org> provided several clean up fixes, and man page updates - Scott Reynolds <email@example.com> provided various fixes - Tyler Retzlaff <firstname.lastname@example.org> provided SSL support, cgi-bin fixes and much other random other stuff - Steve Rumble <email@example.com> provided the -V option. - ISIHARA Takanori <firstname.lastname@example.org> provided a man page fix - <email@example.com> provided chroot and change-to-user support, and other various fixes There are probably others I have forgotten (let me know if you care)
httpd does not handled HTTP/1.1 chunked input from the client yet. NetBSD 5.0_RC4 March 3, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: