HARDCLOCK(9) NetBSD Kernel Developer's Manual HARDCLOCK(9)
hardclock -- real-time timer
void hardclock(struct clockframe *frame);
The hardclock() function is called hz(9) times per second. It implements the real-time system clock. The argument frame is an opaque, machine- dependent structure that encapsulates the previous machine state. The hardclock() performs different tasks such as: · Run the current process's virtual and profile time (decrease the corresponding timers, if they are activated, and generate SIGVTALRM or SIGPROF, respectively). · Increment the time-of-day, taking care of any ntpd(8) or adjtime(2) induced changes and leap seconds, as well as any necessary compensations to keep in sync with PPS signals or external clocks, if support for this is in the kernel (see options(4)). · Schedule softclock interrupts if any callouts should be trig- gered (see callout(9)).
adjtime(2), ntp_adjtime(2), signal(7), ntpd(8), callout(9), hz(9) NetBSD 8.1 March 25, 2010 NetBSD 8.1
You can also request any man page by name and (optionally) by section: