GUSPNP(4) NetBSD Kernel Interfaces Manual GUSPNP(4)
guspnp -- Am78C201 audio device driver
guspnp* at isapnp? audio* at audiobus? There should be no limit caused by the driver on the number of drivers or cards active in the system.
The guspnp driver provides support for audio subsystems using the Inter- wave (Am78C20x) family of ICs, usually the Gravis Ultrasound Plug and Play. Unlike the gus driver guspnp driver does not require any local memory for the IC, but uses the codec for both playback and recording. The guspnp driver can simultaneously playback and record 8- and 16-bit samples at frequencies from 5.51kHz to 48kHz. The guspnp driver relies on isapnp to allocate suitable resources for it. This version of the driver only uses the first logical device of the five the Interwave IC has. The four unused logical devices are the ATAPI CD- ROM device, PnP Joystick device, legacy soundcard emulation device (SoundBlaster) and MIDI serial device. Support for at least ATAPI CD-ROM and Joystick is being worked on. This version of the driver will use 1 IRQ and 2 DRQs.
Cards supported by the guspnp driver include: Gravis Ultrasound PNP, and compatibles
audio(4), gus(4), isapnp(4)
Interwave(tm) IC Am78C201/202 Programmer's Guide Rev. 2. 1996. Advanced Micro Devices.
The guspnp driver appeared in NetBSD 1.3.
Kari Mettinen <Kari.Mettinen@helsinki.fi>, University of Helsinki.
Sometimes you can cause a hiss on either left or right channel, or both. You can usually make it disappear by playing random data, however this might not be a very nice thing to your audio equipment, but it is the only way I have found out to be effective. Only the Codec is used in this version of the driver, therefore only 2 channels are supported (left and right). Also sound quality is probably worse at lower kHz compared to playing through the synthesizer which does interpolation. If the implementation has a 'bad' oscillator, using frequencies 44.8kHz and 38.4kHz will result in incorrect playback frequency. The author has a GUS PnP Pro which displays this behavior. Other members of the Interwave family have not been tested and don't have the glue needed to make them work. Should someone need to implement it, not many changes in the existing code are needed. Output voltage control in register CFIG2  should be set differently for some other members of the family. Other architectures than i386 haven't been tested. The bus_space abstrac- tion has been used from the beginning, so it should work. NetBSD 9.0 June 22, 2005 NetBSD 9.0
You can also request any man page by name and (optionally) by section: