GENFB(4) NetBSD Kernel Interfaces Manual GENFB(4)
genfb -- generic framebuffer console driver
genfb* at pci? genfb* at sbus? wsdisplay* at genfb?
The genfb driver provides support for generic framebuffers that have no native driver. All it needs are some parameters to describe the frame- buffer and an address. PCI When attaching to a pci(4) bus the driver is configured via device prop- erties: width (uint32) Width in pixels. height (uint32) Height in pixels. stride (uint32) Line size in bytes. depth (uint32) Bits per pixel. is_console (bool) If true, genfb will try to become the system console. address (uint32) Bus address of the framebuffer. SBus When attaching to sbus(4) all those parameters are retrieved from the firmware.
pci(4), sbus(4), wscons(4), wsdisplay(4)
There is no way to change the color map even when the firmware supports it. The pci(4) bus frontend has only been tested on macppc and requires machine dependent code to pass the properties mentioned above. So far only macppc provides them. NetBSD 5.0_RC4 April 12, 2007 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: