EX(4) NetBSD Kernel Interfaces Manual EX(4)
ex -- driver for 3Com Fast EtherLink XL (3c900, 3c905, 3c980) and similar PCI bus and cardbus Ethernet interfaces
ex* at cardbus? function ? ex* at pci? dev ? function ?
3Com Ethernet and Fast Ethernet cards supported by the ex driver include: 3c450-TX 10/100 Ethernet 3c555 MiniPCI 10/100 Ethernet 3c575-TX Ethernet 3c575B-TX Ethernet 3c575CT Ethernet 3c656 MiniPCI 10/100 Ethernet 3c656B MiniPCI 10/100 Ethernet 3c656C MiniPCI 10/100 Ethernet 3c900-TPO Ethernet 3c900-COMBO Ethernet 3c900B-TPC Ethernet 3c900B-TPO Ethernet 3c900B-COMBO Ethernet 3c905-T4 10/100 Ethernet 3c905-TX 10/100 Ethernet 3c905B-COMBO 10/100 Ethernet 3c905B-FX 10/100 Ethernet 3c905B-T4 10/100 Ethernet 3c905B-TX 10/100 Ethernet 3c905CX-TX 10/100 Ethernet 3c980 Server Adapter 10/100 Ethernet 3c980C-TXM 10/100 Ethernet 3cSOHO100-TX 10/100 Ethernet All versions of the EtherLink XL (except the older 3c900 and 3c905) sup- port IPv4/TCP/UDP checksumming in hardware. The ex driver supports this feature of the chip. See ifconfig(8) for information on how to enable this feature.
Some of these network interfaces support the Media Independent Interface (MII), a bus which can have at least one arbitrary Physical interface (PHY) chip on it. NetBSD supports MII and has separate drivers for many different PHY chips, including ukphy(4), a generic PHY driver that can support many PHY chips that NetBSD does not yet have a specific driver for. Support for the PHY found on a given NIC must be configured into a NetBSD kernel config(1) for this driver to work properly in those cases. See ifmedia(4), and mii(4).
%s: adapter failure (%x) %s: can't allocate download descriptors, error = %d %s: can't allocate or map rx buffers %s: can't allocate upload descriptors, error = %d %s: can't create download desc. DMA map, error = %d %s: can't create rx DMA map %d, error = %d %s: can't create tx DMA map %d, error = %d %s: can't create upload desc. DMA map, error = %d %s: can't load download desc. DMA map, error = %d %s: can't load mbuf chain, error = %d %s: can't load rx buffer, error = %d %s: can't load upload desc. DMA map, error = %d %s: can't map download descriptors, error = %d %s: can't map upload descriptors, error = %d %s: fifo underrun (%x) @%d %s: jabber (%x) %s: receive stalled %s: too many segments, %s: uplistptr was 0 host too slow to serve incoming packets
cardbus(4), exphy(4), ifmedia(4), intro(4), mii(4), pci(4), ifconfig(8) NetBSD 8.1 October 30, 2007 NetBSD 8.1
You can also request any man page by name and (optionally) by section: