DKCTL(8) NetBSD System Manager's Manual DKCTL(8)
dkctl -- program to manipulate disks
dkctl device command [arg [...]]
dkctl allows a user or system administrator to manipulate and configure disks in various ways. It is used by specifying a disk to manipulate, the command to perform, and any arguments the command may require.
The following commands are supported: getcache Get and display the cache enables for the specified device. setcache none | r | w | rw [save] Set the cache enables for the specified device. The enables are as follows: none Disable all caches on the disk. r Enable the read cache, and disable all other caches on the disk. w Enable the write cache, and disable all other caches on the disk. rw Enable both the read and write caches on the disk. save If specified, and the cache enables are savable, saves the cache enables in the disk's non-volatile parameter storage. synccache [force] Causes the cache on the disk to be synchronized, flushing all dirty write cache blocks to the media. If force is specified, the cache synchronization com- mand will be issued even if the kernel does not believe that there are any dirty cache blocks in the disk's cache. keeplabel [yes | no] Specify to keep or drop the in-core disklabel on the last close of the disk device. (Keep if yes is spec- ified, drop if no is specified.) badsector flush | list | retry Used for managing the kernel's bad sector list for wd(4) devices. The software bad sector list is only maintained if the option ``WD_SOFTBADSECT'' was spec- ified on kernel configuration. flush Clears the in kernel list of bad sec- tors. list Prints out the list of bad sector ranges recorded by the kernel. retry Flushes the in kernel list and then retries all of the previously recorded bad sectors, causing the list to self update. This option can only be used with character devices. addwedge name startblk blkcnt ptype Define a ``wedge'' on the specified disk starting at block number startblk and spanning blkcnt blocks. The wedge will have the volume name name and the par- tition type ptype. The device name of the virtual block device assigned to the wedge will be displayed after the wedge has been successfully created. See dk(4) for more information about disk wedges. delwedge dk Delete the wedge specified by its device name dk from the specified disk. getwedgeinfo Display information about the specified disk wedge. listwedges List all of the wedges configured on the specified disk. strategy [name] Get and set the disk I/O scheduler (buffer queue strategy) on the drive. If you do not provide a name argument, the currently selected strategy will be shown. To set the bufq strategy, the name argument must be specified. name must be the name of one of the built-in kernel disk I/O schedulers. To get the list of supported schedulers, use the following com- mand: $ sysctl kern.bufq.strategies
ioctl(2), dk(4), sd(4), wd(4), disklabel(5), atactl(8), scsictl(8)
The dkctl command first appeared in NetBSD 1.6.
The dkctl command was written by Jason R. Thorpe of Wasabi Systems, Inc. NetBSD 5.0_RC4 December 26, 2005 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: