DHCPCD(8) System Manager's Manual DHCPCD(8)
dhcpcd -- an RFC 2131 compliant DHCP client
dhcpcd [-bdknpqABDEGKLTV] [-c, --script script] [-f, --config file] [-h, --hostname hostname] [-i, --vendorclassid vendorclassid] [-l, --leasetime seconds] [-m, --metric metric] [-o, --option option] [-r, --request address] [-s, --inform address[/cidr]] [-t, --timeout seconds] [-u, --userclass class] [-v, --vendor code, value] [-C, --nohook hook] [-F, --fqdn FQDN] [-I, --clientid clientid] [-O, --nooption option] [-Q, --require option] [-X, --blacklist address] interface dhcpcd -k, --release interface dhcpcd -x, --exit interface
dhcpcd is an implementation of the DHCP client specified in RFC 2131. dhcpcd gets the host information (IP address, routes, etc) from a DHCP server and configures the network interface of the machine on which it is running. dhcpcd then runs the configuration script which writes DNS information to resolvconf(8), if available, otherwise directly to /etc/resolv.conf. If the hostname is currenly blank, (null) or localhost then dhcpcd sets the hostname to the one supplied by the DHCP server. dhcpcd then daemonises and waits for the lease renewal time to lapse. Then it attempts to renew its lease and reconfigure if the new lease changes. Local Link configuration If dhcpcd failed to obtain a lease, it probes for a valid IPv4LL address (aka ZeroConf, aka APIPA). Once obtained it restarts the process of looking for a DHCP server to get a proper address. When using IPv4LL, dhcpcd nearly always succeeds and returns an exit code of 0. In the rare case it fails, it normally means that there is a reverse ARP proxy installed which always defeats IPv4LL probing. To dis- able this behaviour, you can use the -L, --noipv4ll option. Hooking into DHCP events dhcpcd runs /libexec/dhcpcd-run-hooks, or the script specified by the -c, --script option. This script runs each script found in /libexec/dhcpcd-hooks in a lexical order. The default installation sup- plies the scripts 01-test, 10-mtu, 20-resolv.conf and 30-hostname. You can disable each script by using the -C, --nohook option. See dhcpcd-run-hooks(8) for details on how these scripts work. dhcpcd cur- rently ignores the exit code of the script. Fine tuning You can fine tune the behaviour of dhcpcd with the following options: -b, --background Background immediately. This is useful for startup scripts which don't disable link messages for carrier status. -c, --script script Use this script instead of the default /libexec/dhcpcd-run-hooks. -d, --debug Echo debug and informational messages to the console. Subsequent debug options stop dhcpcd from daemonising. -f, --config file Specify a config to load instead of /etc/dhcpcd.conf. dhcpcd always processes the config file before any command line options. -h, --hostname hostname By default, dhcpcd sends the current hostname to the DHCP server so it can register in DNS. You can use this option to specify the hostname sent, or an empty string to stop any hostname from being sent. -i, --vendorclassid vendorclassid Override the vendorclassid field sent. The default is dhcpcd <version>. If not set then none is sent. -k, --release This causes an existing dhcpcd process running on the interface to release its lease, deconfigure the interface and then exit. dhcpcd then waits until this process has exited. -l, --leasetime seconds Request a specific lease time in seconds. By default dhcpcd does not request any lease time and leaves the it in the hands of the DHCP server. -m, --metric metric Added routes will use the metric on systems where this is sup- ported (presently only Linux). Route metrics allow the addition of routes to the same destination across different interfaces, the lower the metric the more it is preferred. -o, --option option Request the DHCP option variable for use in /libexec/dhcpcd-run-hooks. -n, --rebind Notifies an existing dhcpcd process running on the interface to rebind it's lease. dhcpcd will not re-configure itself or use any other command line arguments. dhcpcd will timeout the rebind after 30 seconds at which point the lease will be expired and dhcpcd will enter the discovery state to obtain a new lease. Use the -t, --timeout option to change this. If dhcpcd is not run- ning, then it starts up as normal. This option used to be renew, but rebind is more accurate as we need to broadcast the request instead of unicasting. -p, --persistent dhcpcd normally deconfigures the interface and configuration when it exits. Sometimes, this isn't desirable if for example you have root mounted over NFS. You can use this option to stop this from happening. -r, --request [address] dhcpcd normally sends a DHCP DISCOVER to find servers to offer an address. dhcpcd then requests the address used. You can use this option to skip the BROADCAST step and just request the address. The downside is if you request an address the DHCP server does not know about or the DHCP server is not authorative, it will remain silent. In this situation, we go back to the init state and DISCOVER again. If no address is given then the first address currently assigned to the interface is used. -s, --inform [address[/cidr]] Behaves like -r, --request as above, but sends a DHCP INFORM instead of a REQUEST. This does not get a lease as such, just notifies the DHCP server of the address in use. You should also include the optional cidr network number in-case the address is not already configured on the interface. dhcpcd remains running and pretends it has an infinite lease. dhcpcd will not de-con- figure the interface when it exits. If dhcpcd fails to contact a DHCP server then it returns a failure instead of falling back on IPv4LL. -t, --timeout seconds Timeout after seconds, instead of the default 30. A setting of 0 seconds causes dhcpcd to wait forever to get a lease. -u, --userclass class Tags the DHCP message with the userclass class. DHCP servers use this give members of the class DHCP options other than the default, without having to know things like hardware address or hostname. -v, --vendor code,value Add an enscapulated vendor option. code should be between 1 and 254 inclusive. Examples. Set the vendor option 01 with an IP address. dhcpcd -v 01,192.168.0.2 eth0 Set the vendor option 02 with a hex code. dhcpcd -v 02,01:02:03:04:05 eth0 Do the above and set a third option with a string and not an IP address. dhcpcd -v 01,192.168.0.2 -v 02,01:02:03:04:05 -v 03,\"192.168.0.2\" eth0 -x, --exit This will signal an existing dhcpcd process running on the interface to deconfigure the interface and exit. dhcpcd then waits until this process has exited. -D, --duid Generate an RFC 4361 compliant clientid. This requires persis- tent storage and not all DHCP servers work with it so it's not enabled by default. dhcpcd generates the DUID and stores in it /etc/dhcpcd.duid This file should not be copied to other hosts. -E, --lastlease If dhcpcd cannot obtain a lease, then try to use the last lease acquired for the interface. If the -p, --persistent option is not given then the lease is used if it hasn't expired. -F, --fqdn fqdn Requests that the DHCP server updates DNS using FQDN instead of just a hostname. Valid values for fqdn are disable, none, ptr and both. The current hostname or the hostname specified using the -h, --hostname option must be a FQDN. dhcpcd itself never does any DNS updates. dhcpcd encodes the FQDN hostname as speci- fied in RFC1035. -I, --clientid clientid Send the clientid. If the string is of the format 01:02:03 then it is encoded as hex. For interfaces whose hardware address is longer than 8 bytes, or if the clientid is an empty string then dhcpcd sends a default clientid of the hardware family and the hardware address. Restriciting behaviour dhcpcd will try to do as much as it can by default. However, there are sometimes situations where you don't want the things to be configured exactly how the the DHCP server wants. Here are some options that deal with turning these bits off. -q, --quiet Quiet dhcpcd on the command line, only warnings and errors will be displayed. The messages are still logged though. -A, --noarp Don't request or claim the address by ARP. This also disables IPv4LL. -B, --nobackground Don't run in the background when we acquire a lease. This is mainly useful for running under the control of another process, such as a debugger or a network manager. -C, --nohook script Don't run this hook script. Matches full name, or prefixed with 2 numbers optionally ending with .sh. So to stop dhcpcd from touching your DNS or MTU settings you would do:- dhcpcd -C resolv.conf -C mtu eth0 -G, --nogateway Don't set any default routes. -K, --nolink Don't receive link messages for carrier status. You should only have to use this with buggy device drivers or running dhcpcd through a network manager. -L, --noipv4ll Don't use IPv4LL (aka APIPA, aka Bonjour, aka ZeroConf). -O, --nooption option Don't request the specified option. If no option given, then don't request any options other than those to configure the interface and routing. -Q, --require option Requires the option to be present in all DHCP messages, otherwise the message is ignored. -T, --test On receipt of OFFER messages just call /libexec/dhcpcd-run-hooks with the reason of TEST which echo's the DHCP variables found in the message to the console. The interface configuration isn't touched and neither are any configuration files. -V, --variables Display a list of option codes and the associated variable for use in dhcpcd-run-hooks(8). -X, --blacklist address Ignores all DHCP messages which have this address as the server ID. This may be expanded in future releases to ignore all pack- ets matching either the IP or hardware address.
dhcpcd requires a Berkley Packet Filter, or BPF device on BSD based sys- tems and a Linux Socket Filter, or LPF device on Linux based systems.
/etc/dhcpcd.conf Configuration file for dhcpcd. If you always use the same options, put them here. /etc/dhcpcd.duid Text file that holds the DUID used to identify the host. /libexec/dhcpcd-run-hooks Bourne shell script that is run to configure or deconfigure an interface. /libexec/dhcpcd-hooks A directory containing bourne shell scripts that are run by the above script. Each script can be disabled by using the -C, --nohook option described above. /var/db/dhcpcd-interface.lease The actual DHCP message send by the server. We use this when reading the last lease and use the files mtime as when it was issued. /var/run/dhcpcd-interface.pid Stores the PID of dhcpcd running on the interface.
dhcpcd.conf(5), dhcpcd-run-hooks(8), resolv.conf(5), resolvconf(8),
RFC 2131, RFC 2132, RFC 2855, RFC 3004, RFC 3361, RFC 3396, RFC 3397, RFC 3442, RFC 3927, RFC 4361, RFC 4390, RFC 4702.
Roy Marples <firstname.lastname@example.org>
Please report them to http://roy.marples.name/projects/dhcpcd NetBSD 5.0_RC4 November 18, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: