CORETEMP(4) NetBSD Kernel Interfaces Manual CORETEMP(4)
coretemp -- Intel Core on-die digital thermal sensor
coretemp* at cpu?
The coretemp driver provides support for the on-die digital thermal sen- sor present on Intel Core and newer CPUs. The temperatures can be observed by using the envsys(4) API or the envstat(8) command. Temperatures are reported for each core separately.
The coretemp driver is able to send a critical event to the powerd(8) daemon. The script /etc/powerd/scripts/sensor_temperature will be exe- cuted by the daemon (if running) when the limit has been reached.
envsys(4), envstat(8), powerd(8) Michael Berktold and Tian Tian (Intel Corporation), CPU Monitoring With DTS/PECI, White Paper, http://edc.intel.com/Download.aspx?id=2612, September 2010.
The coretemp driver first appeared in FreeBSD 7.0. It was later ported to NetBSD 5.0.
The coretemp driver was written by Rui Paulo <rpaulo@FreeBSD.org> as part of a Google Summer of Code project. It was adapted to NetBSD by Juan Romero Pardines. NetBSD 8.1 February 23, 2010 NetBSD 8.1
You can also request any man page by name and (optionally) by section: