BTHUB(4) NetBSD Kernel Interfaces Manual BTHUB(4)
bthub -- Bluetooth Remote Device Hub
bthub* at bcsp? bthub* at bt3c? bthub* at btbc? bthub* at btuart? bthub* at sbt? bthub* at ubt? bthidev* at bthub? btmagic* at bthub? btsco* at bthub?
The bthub device is used to attach remote Bluetooth devices to the sys- tem, and will attach to Bluetooth controllers as they are enabled.
Normally, Bluetooth Remote Devices will be configured on the bthub using the btdevctl(8) program, which passes a proplib(3) dictionary to the con- trol file /dev/bthub with the BTDEV_ATTACH and BTDEV_DETACH ioctl(2) com- mands. The following properties are used by bthub: local-bdaddr Local BD_ADDR. This required property should be a six byte data blob. remote-bdaddr Remote BD_ADDR. This required property should be a six byte data blob. service-name Service name. This required property should be a string indicating the service to configure, and may be one of the following: HF Handsfree, see btsco(4). HID Human Interface Device, see bthidev(4). HSET Headset, see btsco(4). Properties used by the configured device are listed in the appropriate device manual page.
bluetooth(4), bthidev(4), btmagic(4), btsco(4), btdevctl(8)
The bthub driver was written by Iain Hibbert under the sponsorship of Itronix, Inc. and first appeared in NetBSD 4.0. NetBSD 9.0 October 17, 2010 NetBSD 9.0
You can also request any man page by name and (optionally) by section: