BTATTACH(8) NetBSD System Manager's Manual BTATTACH(8)
btattach -- attach serial lines as Bluetooth HCI interfaces
btattach [-dfop] [-i speed] [type] tty speed
btattach is used to assign a tty line to a Bluetooth Host Controller Interface using the btuart(4) or bcsp(4) line disciplines, and can optionally initialize the line for a given device type before activating the line discipline. Supported types are: bcm2035 Broadcom BCM2035 bcsp Generic BCSP (BlueCore Serial Protocol) bgb2xx Philips BGB2xx module btuart Generic UART (this is the default) csr Cambridge Silicon Radio Casira serial adaptor, or Brainboxes serial dongle (BL642) ericsson Ericsson based modules digi Digianswer based cards st ST Microelectronics minikits based on STLC2410/STLC2415 stlc2500 ST Microelectronics minikits based on STLC2500 swave Silicon Wave kits texas Texas Instruments modules When the line discipline is activated, btattach detaches and sleeps until it receives a SIGHUP. The command line options are as follows: -d debug mode. print initialization IO and do not detach. -f Enable flow control. -i speed Specify an alternate speed for the Bluetooth module to use dur- ing the initialization phase. -o Enable odd parity. -p Enable parity (even parity). Only the super-user may attach a Bluetooth HCI interface.
bcsp(4), bluetooth(4), btuart(4), btconfig(8)
Not all type initializations have been tested.
The btattach program was written with reference to hciattach(8) as pro- vided with the BlueZ tools for Linux and first appeared in NetBSD 5.0.
KIYOHARA Takashi <email@example.com> Iain Hibbert NetBSD 5.0 March 27, 2008 NetBSD 5.0
You can also request any man page by name and (optionally) by section: