BOOTPARAMS(5) NetBSD File Formats Manual BOOTPARAMS(5)
bootparams -- boot parameter database
The bootparams file specifies the boot parameters that diskless(8) clients may request when booting over the network. Each client supported by this server must have an entry in the bootparams file containing the servers and pathnames for its root, area. It may optionally contain swap, dump, and other entry types. Each line in the file (other than comment lines that begin with a #) specifies the client name followed by the pathnames that the client may request by their logical names. Names are matched in a case-insensitive fashion, and may also be wildcarded using shell-style globbing charac- ters. The components of the line are delimited with blank or tab, and may be continued onto multiple lines with a backslash. For example: dummy root=server:/export/dummy/root \ swap=server:/export/dummy/swap \ dump=server:/export/dummy/swap \ gateway=router:255.255.255.0 When the client named "dummy" requests the pathname for its logical "root" it will be given server ``server'' and pathname ``/export/dummy/root'' as the response to its RPC request. netra[1-5]www* root=server:/export/jumpstart/netra_www When any client with a name matching the pattern "netra[1-5]www*" requests the pathname for its logical "root" it will be given server ``server'' and pathname ``/export/jumpstart/netra_www'' as the response to its RPC request. As this example implies, this is useful for setting up Jumpstart servers for Sun clients.
The server does not default to the localhost, and must be filled in.
/etc/bootparams default configuration file
diskless(8), rpc.bootparamd(8) NetBSD 8.1 February 28, 2002 NetBSD 8.1
You can also request any man page by name and (optionally) by section: