BLACKLISTCTL(8) NetBSD System Manager's Manual BLACKLISTCTL(8)
blacklistctl -- display and change the state of blacklistd
blacklistctl dump [-abdnrw]
blacklistctl is a program used to display the state of blacklistd(8) The following options are available: -a Show all database entries, by default it shows only the embryonic ones. -b Show only the blocked entries. -d Increase debugging level. -n Don't display a header. -r Show the remaining blocked time instead of the last activity time. -w Normally the width of addresses is good for IPv4, the -w flag, makes the display wide enough for IPv6 addresses.
Sometimes the reported number of failed attempts can exceed the number of attempts that blacklistd(8) is configured to block. This can happen either because the rule has been removed manually, or because there were more attempts in flight while the rule block was being added. This con- dition is normal; in that case blacklistd(8) will first attempt to remove the existing rule, and then it will re-add it to make sure that there is only one rule active.
blacklistctl appeared in NetBSD 7.
Christos Zoulas NetBSD 7.0 April 29, 2015 NetBSD 7.0
You can also request any man page by name and (optionally) by section: