ATARAID(4) NetBSD Kernel Interfaces Manual ATARAID(4)
ataraid -- software BIOS RAID
pseudo-device ataraid ld* at ataraid? vendtype ? unit ?
The ataraid driver provides support for BIOS-based software RAID con- trollers. These are devices which have some simple support for several basic RAID levels (often RAID 0 and RAID 1), but which require software support to actually perform the RAID function. The BIOS support is largely just to create and recognize the array so that it may be a boot device. The driver currently supports RAID formats from: + Adaptec HostRAID (found in Intel 6300ESB) + Intel MatrixRAID + JMicron RAID + nVidia MediaShield + Promise FastTrak + Via V-RAID (found in many VIA-based motherboards) Status of the logical disk as well as the disks associated with it, can be viewed through the bioctl(8) utility.
The ataraid driver first appeared in NetBSD 2.0.
The ataraid driver was originally adapted from FreeBSD by Jason Thorpe <thorpej@NetBSD.org>.
Not all features of the software RAID are currently recognized or sup- ported. For example, the Adaptec support doesn't recognize when a RAID 1 should be in a ``building'' state, and it does not do the right thing. At least part of the reason for this is that the publically-available information on these formats is quite limited. NetBSD 5.0_RC4 September 16, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: